summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2023-04-12 23:21:44 -0400
committerneeshy2023-04-12 23:21:44 -0400
commit37e42ae3347e43cff9a5d2cfa0223142158dd4a3 (patch)
tree6b9f37753205853c929c4e2e959754764a416303
parent4796e9fe6057d7dd3dec6b5c7ed83e7a7f179bb7 (diff)
downloadaur-37e42ae3347e43cff9a5d2cfa0223142158dd4a3.tar.gz
osu: rewrite and bump
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD81
-rw-r--r--osu-lazer-git.sh3
-rw-r--r--osu-lazer.desktop (renamed from osu-lazer-git.desktop)0
-rw-r--r--osu-lazer.sh2
-rw-r--r--osu-lazer.xml (renamed from osu-lazer-git.xml)0
6 files changed, 56 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f549cdf99ebc..64800a87c082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,27 @@
pkgbase = osu-lazer-git
- pkgdesc = An open source, free-to-win rhythm game
- pkgver = 2022.605.1
+ pkgdesc = rhythm is just a *click* away!
+ pkgver = latest
pkgrel = 1
- url = https://github.com/ppy/osu
- arch = i686
+ url = https://osu.ppy.sh/
arch = x86_64
- arch = arm
- arch = armv6h
- arch = armv7h
- arch = aarch64
license = MIT
- makedepends = dotnet-sdk-6.0
+ license = custom:CC-BY-NC-4.0
+ makedepends = dotnet-sdk-6.0-bin
makedepends = git
- depends = dotnet-runtime-6.0
+ depends = ffmpeg
depends = libgl
+ depends = sdl2
+ depends = dotnet-runtime-6.0-bin
provides = osu-lazer
conflicts = osu-lazer
- options = !strip
- source = osu-lazer-git::git+https://github.com/ppy/osu.git
- source = osu-lazer-git.sh
- source = osu-lazer-git.desktop
- source = osu-lazer-git.xml
+ source = git+https://github.com/ppy/osu.git
+ source = https://github.com/ppy/osu-resources/raw/master/LICENCE.md
+ source = osu-lazer.sh
+ source = osu-lazer.desktop
+ source = osu-lazer.xml
sha256sums = SKIP
- sha256sums = e5db2d7ee3194bee9604f0574b5a7f7d44361f2d9fca3bab36c76a0469bbf632
+ sha256sums = 30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244
+ sha256sums = b645a8653c78b136c4934194b3dce390e854b3c90c43c889631b9ab3b77022af
sha256sums = 0e117a17c394de80db9b9fdd526de3701d6de6ff1141e5fac57985f2573ae102
sha256sums = ee77425386d476f0f45d73e1ef3a0b5a2bbe8c1ad03716a5ff3e6f7afdad1458
diff --git a/PKGBUILD b/PKGBUILD
index 0942c56333e5..235392c1ad6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,58 @@
-# Maintainer: Nguyễn Chính Hữu <huupoke12@gmail.com>
+# Maintainer: neeshy <neeshy@tfwno.gf>
+# Contributor: Nguyễn Chính Hữu <huupoke12@gmail.com>
# Contributor: Ammon Smith <ammon.i.smith@gmail.com>
# Contributor: Nicole Fontenot <nfontenot27@gmail.com>
# Contributor: "Ferdi265" [AUR]
# Contributor: "downbtn" [AUR]
# Contributor: "Roliga" [AUR]
# Contributor: "donaldtrump" [AUR]
-
-pkgname='osu-lazer-git'
-pkgver='2022.605.1'
+pkgname=osu-lazer-git
+_pkgname=osu
+pkgver=latest
pkgrel=1
-pkgdesc='An open source, free-to-win rhythm game'
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url='https://github.com/ppy/osu'
-license=('MIT')
-depends=('dotnet-runtime-6.0' 'libgl')
-makedepends=('dotnet-sdk-6.0' 'git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-options=('!strip')
-source=("${pkgname}::git+https://github.com/ppy/osu.git"
- "${pkgname}.sh"
- "${pkgname}.desktop"
- "${pkgname}.xml")
+pkgdesc="rhythm is just a *click* away!"
+arch=('x86_64')
+url="https://osu.ppy.sh/"
+license=('MIT' 'custom:CC-BY-NC-4.0')
+depends=('ffmpeg' 'libgl' 'sdl2' 'dotnet-runtime-6.0-bin')
+makedepends=('dotnet-sdk-6.0-bin' 'git')
+provides=('osu-lazer')
+conflicts=('osu-lazer')
+source=("git+https://github.com/ppy/osu.git"
+ "https://github.com/ppy/osu-resources/raw/master/LICENCE.md"
+ "osu-lazer.sh"
+ "osu-lazer.desktop"
+ "osu-lazer.xml")
sha256sums=('SKIP'
- 'e5db2d7ee3194bee9604f0574b5a7f7d44361f2d9fca3bab36c76a0469bbf632'
+ '30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244'
+ 'b645a8653c78b136c4934194b3dce390e854b3c90c43c889631b9ab3b77022af'
'0e117a17c394de80db9b9fdd526de3701d6de6ff1141e5fac57985f2573ae102'
'ee77425386d476f0f45d73e1ef3a0b5a2bbe8c1ad03716a5ff3e6f7afdad1458')
pkgver() {
- cd "${pkgname}"
- printf "'%s'" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
build() {
- cd "${pkgname}"
- rm -rf 'compiled'
- env DOTNET_CLI_TELEMETRY_OPTOUT="${DOTNET_CLI_TELEMETRY_OPTOUT-1}" dotnet publish 'osu.Desktop' \
- --no-self-contained --configuration 'Release' \
- --runtime "$(dotnet --info | grep -F 'RID' | cut -d ':' -f 2 | tr -d '[:space:]')" \
- --output 'compiled'
+ cd "$srcdir/$_pkgname"
+ DOTNET_CLI_TELEMETRY_OPTOUT="1" dotnet publish osu.Desktop \
+ --framework net6.0 \
+ --configuration Release \
+ --use-current-runtime \
+ --no-self-contained \
+ --output output
}
package() {
- # Launcher, Desktop entry, MIME
- install -D -m 755 "${pkgname}.sh" "${pkgdir}/usr/bin/osu-lazer"
- install -D -m 644 "${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/sh.ppy.osu.lazer.desktop"
- install -D -m 644 "${pkgname}.xml" "${pkgdir}/usr/share/mime/packages/osu-lazer.xml"
-
- # Runtime, Libraries
- cd "${pkgname}/compiled"
- find . -type f -exec \
- install -D -m 644 '{}' "${pkgdir}/usr/lib/osu-lazer/{}" ';'
-
- # Icon, License
- cd ..
- install -D -m 644 'assets/lazer.png' "${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/osu-lazer.png"
- install -D -m 644 'assets/lazer-nuget.png' "${pkgdir}/usr/share/icons/hicolor/128x128/apps/osu-lazer.png"
- install -D -m 644 'LICENCE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+ cd "$srcdir/$_pkgname"
+ install -d "$pkgdir/opt/osu-lazer"
+ cp -r output/* "$pkgdir/opt/osu-lazer"
+ install -Dm755 "$srcdir/osu-lazer.sh" "$pkgdir/usr/bin/osu-lazer"
+ install -Dm644 "$srcdir/osu-lazer.desktop" "$pkgdir/usr/share/applications/osu-lazer.desktop"
+ install -Dm644 "$srcdir/osu-lazer.xml" "$pkgdir/usr/share/mime/packages/osu-lazer.xml"
+ install -Dm644 assets/lazer-nuget.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/osu-lazer.png"
+ install -Dm644 assets/lazer.png "$pkgdir/usr/share/icons/hicolor/1024x1024/apps/osu-lazer.png"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/osu-lazer-git/MIT"
+ install -Dm644 "$srcdir/LICENCE.md" "$pkgdir/usr/share/licenses/osu-lazer-git/CC-BY-NC-4.0"
}
diff --git a/osu-lazer-git.sh b/osu-lazer-git.sh
deleted file mode 100644
index 5798700341e2..000000000000
--- a/osu-lazer-git.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-env DOTNET_CLI_TELEMETRY_OPTOUT="${DOTNET_CLI_TELEMETRY_OPTOUT-1}" \
- dotnet '/usr/lib/osu-lazer/osu!.dll' "$@"
diff --git a/osu-lazer-git.desktop b/osu-lazer.desktop
index ac62d2bc8fff..ac62d2bc8fff 100644
--- a/osu-lazer-git.desktop
+++ b/osu-lazer.desktop
diff --git a/osu-lazer.sh b/osu-lazer.sh
new file mode 100644
index 000000000000..05a93035e801
--- /dev/null
+++ b/osu-lazer.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+DOTNET_CLI_TELEMETRY_OPTOUT="1" exec dotnet /opt/osu-lazer/osu!.dll "$@"
diff --git a/osu-lazer-git.xml b/osu-lazer.xml
index 20585b36a8f8..20585b36a8f8 100644
--- a/osu-lazer-git.xml
+++ b/osu-lazer.xml