summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2018-01-25 22:22:33 -0800
committerAmmon Smith2018-01-25 22:22:33 -0800
commit43aee2fc7fec21587cc5098dddf97bab620c320b (patch)
tree008bf096d8758ffc5cd15d6cac80fed13b9d1c66
parent1cb75408b2333fa6e1a028b2f7f5f03b489db9d9 (diff)
downloadaur-43aee2fc7fec21587cc5098dddf97bab620c320b.tar.gz
Have makepkg clone submodules.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc1610afce4f..8def35f35003 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,11 +14,15 @@ pkgbase = osu-lazer-git
provides = osu-lazer
conflicts = osu-lazer
source = git+https://github.com/ppy/osu.git
+ source = git+https://github.com/ppy/osu-framework
+ source = git+https://github.com/ppy/osu-resources
source = osu-launcher
source = osu-lazer.desktop
source = osu-lazer.png
source = x-osu-lazer.xml
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = c499dbff1d9a8f382e7b3cf4a95b58b9f02fb98e66e50cddb5d7d6c8a5223d2d
sha256sums = 11d29c2654896607f37bc5c8e558ea245d8e3b1b412dcba03033bf1db6580ebe
sha256sums = 3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5
diff --git a/PKGBUILD b/PKGBUILD
index 23cf3ac9ed9b..f3fae67b4e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,11 +19,16 @@ options=()
provides=('osu-lazer')
conflicts=('osu-lazer')
source=('git+https://github.com/ppy/osu.git'
+ 'git+https://github.com/ppy/osu-framework'
+ 'git+https://github.com/ppy/osu-resources'
'osu-launcher'
'osu-lazer.desktop'
'osu-lazer.png'
'x-osu-lazer.xml')
+
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
'c499dbff1d9a8f382e7b3cf4a95b58b9f02fb98e66e50cddb5d7d6c8a5223d2d'
'11d29c2654896607f37bc5c8e558ea245d8e3b1b412dcba03033bf1db6580ebe'
'3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5'
@@ -43,15 +48,21 @@ pkgver() {
git describe --always --tags | sed -E -e 's/^(v|changelog-)//g' -e 's/-/_/g'
}
-build() {
- cd "$srcdir/osu"
+prepare() {
+ cd "${srcdir}/osu"
- # Initialize submodules
+ # Prepare submodules
git submodule init
+ git config submodule.osu-framework.url "${srcdir}/osu-framework"
+ git config submodule.osu-resources.url "${srcdir}/osu-resources"
git submodule update --recursive
# Download dependencies
nuget restore
+}
+
+build() {
+ cd "$srcdir/osu"
# Symlink netstandard for xbuild
mkdir -p "osu.Game/bin/Release"