summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2018-09-15 17:15:54 -0400
committerAmmon Smith2018-09-15 17:15:54 -0400
commit4aa056638da7d44b71651cc86e39a7395513e851 (patch)
treefb1e2e42d01d3a43bbd7f86dc78de92c7f865b63
parent41e19cebc67188d856ce5d6d5beb9610cc3131c6 (diff)
downloadaur-4aa056638da7d44b71651cc86e39a7395513e851.tar.gz
Link Roliga's patch.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rwxr-xr-xosu-launcher2
3 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85a0b003bb6a..7733abe720d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = osu-lazer-git
arch = x86_64
license = MIT
makedepends = mono
- makedepends = msbuild-stable
makedepends = git
depends = dotnet-sdk
depends = ffmpeg
@@ -15,7 +14,6 @@ pkgbase = osu-lazer-git
provides = osu-lazer
conflicts = osu-lazer
source = git+https://github.com/ppy/osu.git
- source = git+https://github.com/ppy/osu-framework
source = git+https://github.com/ppy/osu-resources
source = osu-launcher
source = osu-lazer.desktop
@@ -23,8 +21,7 @@ pkgbase = osu-lazer-git
source = x-osu-lazer.xml
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 09c1cd74f65806aa3064d9eabee440e2d205d8b50cf12bafc41cb338681ba3e9
+ sha256sums = 5e7620261f978a583a86c586754fcee0b6d0e5c12fbbfa939a38175ddaeca141
sha256sums = 2665c47e522ec7762a2a8ff3dcf32f254fd9e5eceac33a162c638f06b0fcb44e
sha256sums = 3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5
sha256sums = d22f0d922856639c7cc5f71bdd620cc8b3eb54af923b1a43703faac217b8b13b
diff --git a/PKGBUILD b/PKGBUILD
index 1258e40f998b..fe6c28a6db7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
# Contributor: Nicole Fontenot <nfontenot27@gmail.com>
+# Contributor: "Roliga" [AUR]
# Contributor: "donaldtrump" [AUR]
pkgname=osu-lazer-git
@@ -10,7 +11,6 @@ arch=('x86_64')
url='https://osu.ppy.sh'
license=('MIT')
makedepends=('mono'
- 'msbuild-stable'
'git')
depends=('dotnet-sdk'
'ffmpeg'
@@ -21,7 +21,6 @@ options=()
provides=('osu-lazer')
conflicts=('osu-lazer')
source=('git+https://github.com/ppy/osu.git'
- 'git+https://github.com/ppy/osu-framework'
'git+https://github.com/ppy/osu-resources'
'osu-launcher'
'osu-lazer.desktop'
@@ -30,8 +29,7 @@ source=('git+https://github.com/ppy/osu.git'
sha256sums=('SKIP'
'SKIP'
- 'SKIP'
- '09c1cd74f65806aa3064d9eabee440e2d205d8b50cf12bafc41cb338681ba3e9'
+ '5e7620261f978a583a86c586754fcee0b6d0e5c12fbbfa939a38175ddaeca141'
'2665c47e522ec7762a2a8ff3dcf32f254fd9e5eceac33a162c638f06b0fcb44e'
'3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5'
'd22f0d922856639c7cc5f71bdd620cc8b3eb54af923b1a43703faac217b8b13b')
@@ -46,7 +44,6 @@ prepare() {
# Prepare submodules
git submodule init
- git config submodule.osu-framework.url "$srcdir/osu-framework"
git config submodule.osu-resources.url "$srcdir/osu-resources"
git submodule update --recursive
@@ -61,7 +58,7 @@ build() {
# Build
export MONO_IOMAP='case'
export TERM='xterm'
- msbuild /property:Configuration=Release
+ dotnet msbuild /property:Configuration=Release
}
package() {
diff --git a/osu-launcher b/osu-launcher
index e766dd15a47f..ae5ef21f6b8c 100755
--- a/osu-launcher
+++ b/osu-launcher
@@ -1,3 +1,3 @@
#!/bin/sh
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib/osu-lazer"
-exec dotnet '/usr/lib/osu-lazer/osu!.dll'
+exec dotnet '/usr/lib/osu-lazer/osu!.dll' "$@"