summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2024-02-05 14:46:56 -0500
committerneeshy2024-02-05 14:47:32 -0500
commite101d61da08d6d545df6a4d64120ff69cd44dc94 (patch)
tree6f8aa936894c8ee61ad2b5a9023a0e9a7df139d0
parentd83566dc45d289951fb774ae9c8f57e5880aaada (diff)
downloadaur-e101d61da08d6d545df6a4d64120ff69cd44dc94.tar.gz
update dotnet version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22fa2cc65b7b..5e320fe2f721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,11 @@ pkgbase = osu-lazer-git
license = MIT
license = custom:CC-BY-NC-4.0
makedepends = git
- makedepends = dotnet-sdk-6.0-bin
+ makedepends = dotnet-sdk
depends = ffmpeg
depends = libgl
depends = sdl2
- depends = dotnet-runtime-6.0-bin
+ depends = dotnet-runtime
provides = osu-lazer
conflicts = osu-lazer
source = git+https://github.com/ppy/osu.git
diff --git a/PKGBUILD b/PKGBUILD
index f1000f8751b3..b1c2ad117c27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@ pkgdesc="rhythm is just a *click* away!"
arch=('x86_64')
url="https://osu.ppy.sh/"
license=('MIT' 'custom:CC-BY-NC-4.0')
-depends=('ffmpeg' 'libgl' 'sdl2' 'dotnet-runtime-6.0-bin')
-makedepends=('git' 'dotnet-sdk-6.0-bin')
+depends=('ffmpeg' 'libgl' 'sdl2' 'dotnet-runtime')
+makedepends=('git' 'dotnet-sdk')
provides=('osu-lazer')
conflicts=('osu-lazer')
source=("git+https://github.com/ppy/osu.git"
@@ -37,7 +37,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
DOTNET_CLI_TELEMETRY_OPTOUT="1" dotnet publish osu.Desktop \
- --framework net6.0 \
+ --framework net8.0 \
--configuration Release \
--use-current-runtime \
--no-self-contained \