summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNguyen Chinh Huu2020-01-08 17:46:49 +0700
committerNguyen Chinh Huu2020-01-08 17:46:49 +0700
commitf6dc57dab4b7738654ad9da75737fa51bf63f203 (patch)
tree20b0d394355bad6e76fc25b5f97fe5c081a67ca3
parente4b4ade354456c9dcb82ef37d5b926340ecaaa44 (diff)
downloadaur-f6dc57dab4b7738654ad9da75737fa51bf63f203.tar.gz
Completely rewrite the package
-rw-r--r--.SRCINFO29
-rw-r--r--NuGet.config7
-rw-r--r--PKGBUILD121
-rwxr-xr-xosu-launcher3
-rw-r--r--osu-lazer.desktop12
-rw-r--r--osu-lazer.pngbin39498 -> 0 bytes
-rw-r--r--osu-lazer.sh2
-rw-r--r--osu-lazer.xml20
-rw-r--r--x-osu-lazer.xml14
9 files changed, 80 insertions, 128 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f8ed180623a..29c38b3b619e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,26 @@
pkgbase = osu-lazer-git
- pkgdesc = Freeware rhythm video game - lazer development version
- pkgver = 2019.1227.0_36_gbeb8e72e1
+ pkgdesc = An open source, free-to-win rhythm game
+ pkgver = 2020.104.0.r72.d33a507d9
pkgrel = 1
- url = https://osu.ppy.sh
- arch = x86_64
+ url = https://github.com/ppy/osu
+ arch = any
license = MIT
makedepends = git
- depends = dotnet-sdk>=3.1.0
+ makedepends = dotnet-sdk>=3.1
+ depends = dotnet-runtime>=3.1
depends = ffmpeg
depends = libgl
- depends = shared-mime-info
provides = osu-lazer
conflicts = osu-lazer
- source = git+https://github.com/ppy/osu.git
- source = git+https://github.com/ppy/osu-resources.git
- source = osu-launcher
+ options = !strip
+ source = osu-lazer::git+https://github.com/ppy/osu.git
+ source = osu-lazer.sh
source = osu-lazer.desktop
- source = osu-lazer.png
- source = x-osu-lazer.xml
+ source = osu-lazer.xml
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 5e7620261f978a583a86c586754fcee0b6d0e5c12fbbfa939a38175ddaeca141
- sha256sums = 2665c47e522ec7762a2a8ff3dcf32f254fd9e5eceac33a162c638f06b0fcb44e
- sha256sums = 3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5
- sha256sums = d22f0d922856639c7cc5f71bdd620cc8b3eb54af923b1a43703faac217b8b13b
+ sha256sums = ce9d5224514170c97012d1bbc652f064223bdecddaa85f16019d50b06d712fa8
+ sha256sums = 6e977d250974783ca02a61cb8cad9b1d8683bcb1ee289d9e1ce2b4ad431b9773
+ sha256sums = 8e7c18bcb146cf161a84025934ef2cbe9395b0008535faaeaca4bc4d56194f8f
pkgname = osu-lazer-git
diff --git a/NuGet.config b/NuGet.config
deleted file mode 100644
index 248aeec9259a..000000000000
--- a/NuGet.config
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<configuration>
- <packageSources>
- <add key="OpenTK" value="https://dotnet.myget.org/F/aspnetcore-ci-dev/api/v3/index.json" />
- <add key="opentk-develop" value="https://www.myget.org/F/opentk-develop" />
- </packageSources>
-</configuration>
diff --git a/PKGBUILD b/PKGBUILD
index 7631710b8c6a..f1227badaef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+# Maintainer: Nguyen Chinh Huu <huupoke12@gmail.com>
+# Contributor: Ammon Smith <ammon.i.smith@gmail.com>
# Contributor: Nicole Fontenot <nfontenot27@gmail.com>
# Contributor: "Ferdi265" [AUR]
# Contributor: "downbtn" [AUR]
@@ -6,97 +7,57 @@
# Contributor: "donaldtrump" [AUR]
pkgname=osu-lazer-git
-pkgver=2019.1227.0_36_gbeb8e72e1
+pkgver=2020.104.0.r72.d33a507d9
pkgrel=1
-pkgdesc='Freeware rhythm video game - lazer development version'
-arch=('x86_64')
-url='https://osu.ppy.sh'
+pkgdesc="An open source, free-to-win rhythm game"
+arch=('any')
+url="https://github.com/ppy/osu"
license=('MIT')
-makedepends=('git')
-depends=(
- 'dotnet-sdk>=3.1.0'
- 'ffmpeg'
- 'libgl'
- 'shared-mime-info'
-)
-optdepends=()
-options=()
-provides=('osu-lazer')
-conflicts=('osu-lazer')
-source=(
- 'git+https://github.com/ppy/osu.git'
- 'git+https://github.com/ppy/osu-resources.git'
- 'osu-launcher'
+groups=()
+depends=('dotnet-runtime>=3.1' 'ffmpeg' 'libgl')
+makedepends=('git' 'dotnet-sdk>=3.1')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=(!strip)
+install=
+source=("${pkgname%-git}::git+https://github.com/ppy/osu.git"
+ 'osu-lazer.sh'
'osu-lazer.desktop'
- 'osu-lazer.png'
- 'x-osu-lazer.xml'
-)
+ 'osu-lazer.xml')
+noextract=()
+sha256sums=('SKIP'
+ 'ce9d5224514170c97012d1bbc652f064223bdecddaa85f16019d50b06d712fa8'
+ '6e977d250974783ca02a61cb8cad9b1d8683bcb1ee289d9e1ce2b4ad431b9773'
+ '8e7c18bcb146cf161a84025934ef2cbe9395b0008535faaeaca4bc4d56194f8f')
-sha256sums=(
- 'SKIP'
- 'SKIP'
- '5e7620261f978a583a86c586754fcee0b6d0e5c12fbbfa939a38175ddaeca141'
- '2665c47e522ec7762a2a8ff3dcf32f254fd9e5eceac33a162c638f06b0fcb44e'
- '3b3a9075f79ca7f2a4fd34eb182a5c1ada6eb118a95e49c1526df516365bbfe5'
- 'd22f0d922856639c7cc5f71bdd620cc8b3eb54af923b1a43703faac217b8b13b'
-)
pkgver() {
- cd "$srcdir/osu"
- git describe --always --tags | sed -E -e 's/^(v|changelog-)//g' -e 's/-/_/g'
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-prepare() {
- cd "$srcdir/osu"
-
- # Prepare submodules
- git submodule init
- git config submodule.osu-resources.url "$srcdir/osu-resources"
- git submodule update --recursive
-
- # Download dependencies
- export TERM='xterm'
- dotnet restore osu.sln
-}
build() {
- cd "$srcdir/osu"
-
- # Build
- export MONO_IOMAP='case'
- export TERM='xterm'
- dotnet build /property:Configuration=Release osu.Desktop
+ cd "$srcdir/${pkgname%-git}"
+ dotnet build -c Release osu.Desktop
}
+
package() {
- # Wrapper script
+ # Launcher, Desktop and MIME
cd "$srcdir"
- mkdir -p "$pkgdir/usr/bin"
- install -m755 'osu-launcher' "$pkgdir/usr/bin/osu-lazer"
-
- # MIME types
- mkdir -p "$pkgdir/usr/share/mime/packages"
- install -m644 "x-${pkgname%-git}.xml" "$pkgdir/usr/share/mime/packages/x-${pkgname%-git}.xml"
-
- # Add .desktop file
- mkdir -p "$pkgdir/usr/share/applications"
- install -m644 "${pkgname%-git}.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
-
- # Application icon
- mkdir -p "$pkgdir/usr/share/pixmaps"
- install -m644 "${pkgname%-git}.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
-
- # Copy license file
- mkdir -p "$pkgdir/usr/share/licenses/${pkgname%-git}"
- install -m644 "$srcdir/osu/LICENCE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
- ln -s LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENCE"
-
- # Copy binaries
- cd "$srcdir/osu/osu.Desktop/bin/Release/netcoreapp3.1"
- mkdir -p "$pkgdir/usr/lib/${pkgname%-git}"
- for file in *.json *.dll *.pdb runtimes/linux-x64/native/*.so; do
- install -m755 "$file" "$pkgdir/usr/lib/${pkgname%-git}/${file##*/}"
- done
+ install -Dm755 osu-lazer.sh "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 osu-lazer.desktop "$pkgdir/usr/share/applications/sh.ppy.osu.${pkgname%-git}.desktop"
+ install -Dm644 osu-lazer.xml "$pkgdir/usr/share/mime/packages/${pkgname%-git}.xml"
+
+ # Libraries
+ cd "$srcdir/${pkgname%-git}/osu.Desktop/bin/Release/netcoreapp3.1"
+ find . -maxdepth 1 -type f \! -name 'osu!' -exec install -Dm755 "{}" "$pkgdir/usr/lib/${pkgname%-git}/{}" \;
+
+ # Icon and License
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm644 assets/lazer.png "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: set sw=4 ts=4 noet:
diff --git a/osu-launcher b/osu-launcher
deleted file mode 100755
index ae5ef21f6b8c..000000000000
--- a/osu-launcher
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib/osu-lazer"
-exec dotnet '/usr/lib/osu-lazer/osu!.dll' "$@"
diff --git a/osu-lazer.desktop b/osu-lazer.desktop
index a51d9f5c7825..d62c3024bb9f 100644
--- a/osu-lazer.desktop
+++ b/osu-lazer.desktop
@@ -2,14 +2,10 @@
Type=Application
Version=1.0
Name=osu!lazer
+GenericName=Rhythm game
+Comment=An open source, free-to-win rhythm game
+Exec=osu-lazer %F
Icon=osu-lazer
-MimeType=application/x-osu-lazer-beatmap;
-Comment=Rythm is only a click away!
-Comment[fr]=Le rythme n'est qu'à un clic!
-Comment[zh]=节奏只是点击一下!
-Comment[ja]=リズムはクリックするだけです!
-Path=/usr/lib/osu-lazer
-Exec=/usr/bin/osu-lazer
+MimeType=application/x-osu-beatmap;application/x-osu-skin;application/x-osu-replay;
Terminal=false
Categories=Game
-X-Desktop-File-Install-Version=0.23
diff --git a/osu-lazer.png b/osu-lazer.png
deleted file mode 100644
index 44aad2a4dcd2..000000000000
--- a/osu-lazer.png
+++ /dev/null
Binary files differ
diff --git a/osu-lazer.sh b/osu-lazer.sh
new file mode 100644
index 000000000000..0d909e296236
--- /dev/null
+++ b/osu-lazer.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+dotnet /usr/lib/osu-lazer/osu\!.dll "$@"
diff --git a/osu-lazer.xml b/osu-lazer.xml
new file mode 100644
index 000000000000..a4d1c0e14c43
--- /dev/null
+++ b/osu-lazer.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-osu-beatmap">
+ <comment>osu! Beatmap</comment>
+ <icon name="application-x-osu-lazer"/>
+ <glob pattern="*.osz"/>
+ </mime-type>
+
+ <mime-type type="application/x-osu-skin">
+ <comment>osu! Skin</comment>
+ <icon name="application-x-osu-lazer"/>
+ <glob pattern="*.osk"/>
+ </mime-type>
+
+ <mime-type type="application/x-osu-replay">
+ <comment>osu! Replay</comment>
+ <icon name="application-x-osu-lazer"/>
+ <glob pattern="*.osr"/>
+ </mime-type>
+</mime-info>
diff --git a/x-osu-lazer.xml b/x-osu-lazer.xml
deleted file mode 100644
index 0e547b8981cb..000000000000
--- a/x-osu-lazer.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/x-osu-lazer-beatmap">
- <comment>osu! Beatmap</comment>
- <!-- iso 639-1 codes go in xml:lang -->
- <comment xml:lang="fr">osu! Beatmap</comment>
- <comment xml:lang="hk">osu! 譜面</comment>
- <comment xml:lang="ja">osu! Beatmap</comment>
- <comment xml:lang="zh">osu! 谱面</comment>
- <icon name="osu-lazer"/>
- <glob-deleteall/>
- <glob pattern="*.osz"/>
- </mime-type>
-</mime-info>