summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2016-04-11 02:05:13 +0200
committerChristoph Haag2016-04-11 02:05:13 +0200
commit4fef6832247db506e30d2be0dbb2da19368babfb (patch)
tree3847b14e136ce81db11788065d578fd987fb6a3d
downloadaur-4fef6832247db506e30d2be0dbb2da19368babfb.tar.gz
initial, doesn't build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ab10405e423
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = osvr-config-git
+ pkgdesc = OSVR-Config is a utility to configure the OSVR Server, and gives you access to a few OSVR-related tools.
+ pkgver = r75.721c9df
+ pkgrel = 1
+ url = https://github.com/OSVR/OSVR-Config
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = cmake
+ depends = osvr-core-git
+ depends = asp.net-bin
+ depends = bower
+ depends = gulp
+ depends = libcurl-gnutls
+ source = osvr-config::git+https://github.com/OSVR/OSVR-Config.git
+ md5sums = SKIP
+
+pkgname = osvr-config-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13d4012daf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname=osvr-config-git
+pkgver=r75.721c9df
+pkgrel=1
+pkgdesc="OSVR-Config is a utility to configure the OSVR Server, and gives you access to a few OSVR-related tools."
+arch=(i686 x86_64)
+url="https://github.com/OSVR/OSVR-Config"
+#license=('GPL')
+#install=osvr-config.install
+makedepends=('git' 'cmake')
+depends=('osvr-core-git' 'asp.net-bin' 'bower' 'gulp' 'libcurl-gnutls') #TODO: add more deps # why libcurl-gnutls?? https://github.com/dotnet/core/issues/37
+source=("osvr-config::git+https://github.com/OSVR/OSVR-Config.git")
+# "Findjsoncpp.cmake")
+
+pkgver() {
+ cd "$srcdir/osvr-config"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd osvr-config
+}
+
+build() {
+ cd osvr-config
+cd src/ConfigUtil
+
+#fuck you, asp.net
+export PATH="$PATH:/usr/lib/asp.net/dnx-coreclr-linux-x64.1.0.0-rc1-update1/bin/"
+
+# make sure it's not LC_ALL=en_US.utf8 or something
+export LC_ALL=en_US.UTF-8
+
+dnu restore
+dnu publish --runtime /usr/lib/asp.net/dnx-coreclr-linux-x64.1.0.0-rc1-update1 --no-source -o ../../artifacts --configuration Release #TODO
+
+}
+
+package() {
+ cd osvr-config
+#TODO
+# make DESTDIR="$pkgdir/" install
+
+}
+md5sums=('SKIP')
+
+# vim:set ts=2 sw=2 et: