summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2020-07-24 03:34:40 +0200
committerChristoph Haag2020-07-24 04:24:08 +0200
commit3526ce92d27304ed83c7a788c13cd324e5b94e02 (patch)
treecf46a87df9b4989553176f3ea56ac8dc4333db40
parent6c47c947f8cd4da634a2d21dfa658bfdc23d7fb4 (diff)
downloadaur-3526ce92d27304ed83c7a788c13cd324e5b94e02.tar.gz
remove patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
-rw-r--r--use_core_profile_unconditionally.diff17
3 files changed, 4 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bbd32cdc7e9..7d9142e6eaac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jan 10 00:05:32 UTC 2018
pkgbase = osvr-rendermanager-git
pkgdesc = TW, ATW and high performance rendering with OpenGL and GLES
- pkgver = v00_06_52.r278.g24398fd
+ pkgver = v00_06_52.r350.g56f9db6
pkgrel = 1
url = https://github.com/sensics/OSVR-RenderManager
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a35af616256a..7166220bff35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=osvr-rendermanager-git
-pkgver=v00_06_52.r312.g32bb995
+pkgver=v00_06_52.r350.g56f9db6
pkgrel=1
pkgdesc="TW, ATW and high performance rendering with OpenGL and GLES"
arch=(i686 x86_64)
@@ -9,11 +9,9 @@ url="https://github.com/sensics/OSVR-RenderManager"
makedepends=('git' 'cmake')
depends=('osvr-core-git' 'eigen') #TODO: add more deps
source=("osvr-rendermanager::git+https://github.com/sensics/OSVR-RenderManager.git"
- "vendor-vrpn::git+https://github.com/vrpn/vrpn.git"
- "use_core_profile_unconditionally.diff")
+ "vendor-vrpn::git+https://github.com/vrpn/vrpn.git")
md5sums=('SKIP'
- 'SKIP'
- '4f58517e2c39fd486f84b34afe7d07ad')
+ 'SKIP')
pkgver() {
cd "$srcdir/osvr-rendermanager"
@@ -37,27 +35,6 @@ prepare() {
# this copies over osvr-core files from the system into the install directory so they would simply be overwritten in /usr/lib
sed -i "/osvrrm_copy_deps(osvr::osvrClientKit osvr::osvrClient osvr::osvrCommon osvr::osvrUtil)/d" CMakeLists.txt
-
- echo
- echo "Patch Rendermanager to use an OpenGL Core Profile?"
- echo "For mesa drivers you should say Y, for proprietary drivers you should say n."
- echo "(Some of the example programs will not work with a Core Profile, this is not a rendermanagager bug, but a result of this patch)"
- echo "For more information refer to"
- echo "https://github.com/sensics/OSVR-RenderManager/issues/68"
- echo "https://github.com/sensics/OSVR-RenderManager/issues/233"
- read -p "[Y/n]? " -n 1 -r
- echo # (optional) move to a new line
- case "$REPLY" in
- y*|Y*|"" )
- echo "Patching rendermanager to use a core profile..."
- git apply -vvv "$srcdir"/use_core_profile_unconditionally.diff
- echo "Patched..."
- ;;
- * )
- echo "Building unpatched..."
- ;;
- esac
- sleep 1
}
build() {
diff --git a/use_core_profile_unconditionally.diff b/use_core_profile_unconditionally.diff
deleted file mode 100644
index cad925bdb8e5..000000000000
--- a/use_core_profile_unconditionally.diff
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/osvr/RenderKit/RenderManagerOpenGL.cpp b/osvr/RenderKit/RenderManagerOpenGL.cpp
-index e637096..0d4811c 100755
---- a/osvr/RenderKit/RenderManagerOpenGL.cpp
-+++ b/osvr/RenderKit/RenderManagerOpenGL.cpp
-@@ -150,12 +150,10 @@ public:
- SDL_GL_SetAttribute(SDL_GL_ALPHA_SIZE, p->bitsPerPixel);
- SDL_GL_SetAttribute(SDL_GL_DEPTH_SIZE, 24);
- SDL_GL_SetAttribute(SDL_GL_ACCELERATED_VISUAL, 1);
--#ifdef __APPLE__
- SDL_GL_SetAttribute(SDL_GL_CONTEXT_MAJOR_VERSION, 3);
- SDL_GL_SetAttribute(SDL_GL_CONTEXT_MINOR_VERSION, 3);
- SDL_GL_SetAttribute(SDL_GL_CONTEXT_PROFILE_MASK,
- SDL_GL_CONTEXT_PROFILE_CORE);
--#endif
-
- // If we have multiple displays, we need to re-use the
- // same context between them. In fact, we always want