summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2022-09-28 00:18:07 +0900
committerAlexandros Theodotou2022-09-28 00:18:07 +0900
commit603c3c49003bcbe615c95d3fc5ca49f1d5597d90 (patch)
treede80824dd7bd5feb0eb989b687497bd793f230f1
downloadaur-603c3c49003bcbe615c95d3fc5ca49f1d5597d90.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9fa8d2601fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ot-simian
+ pkgdesc = Drum synthesizer inspired by the Simmons SDS-V
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://punklabs.com/ot-simian
+ arch = any
+ license = GPL3
+ makedepends = faust
+ makedepends = dub
+ makedepends = ldc
+ source = https://punklabs.com/content/projects/ot-simian/downloads/OneTrick-SIMIAN-1.0.0-Source.zip
+ sha256sums = 7c046141a763ca5ca5324e38fa4bdaf347770e94ca848c1a97a4396cb8223b27
+
+pkgname = ot-simian
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ee14f259e6ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+OneTrick-SIMIAN-1.0.0-Source.zip
+ot-simian-*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd9af890ace0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alexandros Theodotou <alex at zrythm dot org>
+
+pkgname=ot-simian
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Drum synthesizer inspired by the Simmons SDS-V'
+arch=('any')
+url='https://punklabs.com/ot-simian'
+license=('GPL3')
+makedepends=('faust' 'dub' 'ldc')
+source=("https://punklabs.com/content/projects/ot-simian/downloads/OneTrick-SIMIAN-${pkgver}-Source.zip")
+sha256sums=('7c046141a763ca5ca5324e38fa4bdaf347770e94ca848c1a97a4396cb8223b27')
+
+build() {
+ cd "plugin"
+ faust --process-name processDrum -lang dlang -A "DSP/arch" -a custom.d.template -o "DSP_Drum.d" --class-name DSP_Drum "DSP/Simian.dsp"
+ faust --process-name processOutput -lang dlang -A "DSP/arch" -a custom.d.template -o "DSP_Output.d" --class-name DSP_Output "DSP/Simian.dsp"
+
+ # FIXME dplug-build should be packaged separately
+ rm -rf Dplug
+ git clone https://github.com/AuburnSounds/Dplug.git Dplug
+ pushd Dplug/tools/dplug-build
+ dub --compiler ldc2
+ popd
+ cp Dplug/tools/dplug-build/dplug-build ./
+ rm -rf Dplug
+
+ ./dplug-build --build debug --config LV2
+}
+
+package() {
+ cd "plugin"
+
+ # FIXME use install command
+ mkdir -p "$pkgdir/usr/lib/lv2/"
+ cp -r --preserve=mode \
+ 'builds/Linux-64b-LV2/Punk Labs LLC OneTrick SIMIAN.lv2' \
+ "$pkgdir/usr/lib/lv2/Punk Labs LLC OneTrick SIMIAN.lv2"
+}