summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKatie Wolfe2020-08-14 16:33:49 -0400
committerKatie Wolfe2020-08-14 16:33:49 -0400
commit6e82f865433108972d975a6fd6f79f8a81dd2825 (patch)
tree653c8073cf8e8b783a08b9746b4f7cd0d5371450
downloadaur-6e82f865433108972d975a6fd6f79f8a81dd2825.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d317a6c44f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otb-tewi-git
+ pkgdesc = Tiny bitmap font
+ pkgver = r313.a975d38
+ pkgrel = 1
+ url = https://github.com/lucy/tewi-font
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = fonttosfnt
+ provides = otb-tewi
+ conflicts = otb-tewi
+ source = git+https://github.com/lucy/tewi-font.git
+ sha512sums = SKIP
+
+pkgname = otb-tewi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e1a2e9d86ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Katie Wolfe <wolfe@katie.host
+pkgname=otb-tewi-git
+pkgver=r313.a975d38
+pkgrel=1
+pkgdesc='Tiny bitmap font'
+arch=('any')
+url='https://github.com/lucy/tewi-font'
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'fonttosfnt')
+provides=('otb-tewi')
+conflicts=('otb-tewi')
+source=('git+https://github.com/lucy/tewi-font.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/tewi-font"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/tewi-font"
+ for f in *.bdf; do
+ fonttosfnt -v -c -b -g 2 -m 1 -o "${f%.bdf}.otb" "${f}"
+ done
+}
+
+package() {
+ cd "${srcdir}/tewi-font"
+ install -d -m755 "${pkgdir}/usr/share/fonts/misc"
+ install -m644 -t "${pkgdir}/usr/share/fonts/misc/" *.otb
+}