summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorckath2019-08-01 00:03:50 +0200
committerckath2019-08-01 00:03:50 +0200
commit9996d430bf8bbf881d0179287757379c04a50426 (patch)
tree5e706372a056407e9c38bfdaed8bb8581ad22d07
downloadaur-9996d430bf8bbf881d0179287757379c04a50426.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rwxr-xr-xotbconvert.pe4
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6bad66230c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = otb-unifont
+ pkgdesc = GNU Unifont Glyphs
+ pkgver = 12.1.02
+ pkgrel = 1
+ url = https://ftp.gnu.org/gnu/unifont
+ arch = any
+ license = GPL
+ makedepends = fontforge
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = https://ftp.gnu.org/gnu/unifont/unifont-12.1.02/unifont-12.1.02.bdf.gz
+ source = https://ftp.gnu.org/gnu/unifont/unifont-12.1.02/unifont-12.1.02.bdf.gz.sig
+ source = otbconvert.pe
+ validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
+ md5sums = af8a44e7d33b66ef54b2b5b497854b5e
+ md5sums = SKIP
+ md5sums = 8b6d81ad1956b2d7eb5dbead68dacdf4
+
+pkgname = otb-unifont
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d420174d8da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ckat <ckat@teknik.io>
+
+pkgname=otb-unifont
+pkgver=12.1.02
+pkgrel=1
+pkgdesc="GNU Unifont Glyphs"
+arch=('any')
+license=('GPL')
+url="https://ftp.gnu.org/gnu/unifont"
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+makedepends=('fontforge')
+source=("https://ftp.gnu.org/gnu/unifont/unifont-${pkgver}/unifont-${pkgver}.bdf.gz"{,.sig} 'otbconvert.pe')
+validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy
+md5sums=('af8a44e7d33b66ef54b2b5b497854b5e'
+ 'SKIP'
+ '8b6d81ad1956b2d7eb5dbead68dacdf4')
+
+build() {
+ gunzip -d --force "${srcdir}/unifont-${pkgver}.bdf.gz"
+ ./otbconvert.pe "${srcdir}/unifont-${pkgver}.bdf"
+}
+
+package() {
+ cd "${srcdir}"
+ for f in *.otb; do
+ install -Dm 644 "${f}" "${pkgdir}/usr/share/fonts/misc/${f}"
+ done
+}
diff --git a/otbconvert.pe b/otbconvert.pe
new file mode 100755
index 000000000000..1f7013f4ad78
--- /dev/null
+++ b/otbconvert.pe
@@ -0,0 +1,4 @@
+#!/usr/bin/fontforge
+New()
+Import($1);
+Generate($fullname + ".otb")