summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornilas2020-04-20 00:18:06 +0200
committernilas2020-04-20 00:18:06 +0200
commitdd55b27c44c34b420971ac3f5d49cbf0a4c6270c (patch)
tree7fb95735ef7537d459f634174d066ea13ae4eaf2
downloadaur-dd55b27c44c34b420971ac3f5d49cbf0a4c6270c.tar.gz
Add files
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b8cd89025c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = otb-uw_ttyp0
+ pkgdesc = Bitmap monospaced font with unicode support and powerline symbols
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0
+ arch = any
+ license = custom:TTYP0
+ makedepends = git
+ conflicts = uw-ttyp0-font
+ source = otb-uw_ttyp0-1.3-bold.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0-Bold.otb
+ source = otb-uw_ttyp0-1.3-italic.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0-Italic.otb
+ source = otb-uw_ttyp0-1.3.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0.otb
+ source = otb-uw_ttyp0-1.3-ttyp0::https://raw.githubusercontent.com/9las/uw_ttyp0/master/TTYP0
+ md5sums = b7dd09a73936851b7751a9d4f9cdcce6
+ md5sums = 5a0764e704a1ea352533ce018645df29
+ md5sums = c930c72646a59161125dc03801421e5e
+ md5sums = 939cef4d4d6fa3d4124b9116a0121408
+
+pkgname = otb-uw_ttyp0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe48a224d47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nilas Tim Schüsler <nilasschusler at gmail dot com>
+pkgname="otb-uw_ttyp0"
+pkgver=1.3
+pkgrel=1
+pkgdesc="Bitmap monospaced font with unicode support and powerline symbols"
+arch=("any")
+url="http://people.mpi-inf.mpg.de/~uwe/misc/uw-ttyp0"
+license=("custom:TTYP0")
+conflicts=("uw-ttyp0-font")
+md5sums=('b7dd09a73936851b7751a9d4f9cdcce6'
+ '5a0764e704a1ea352533ce018645df29'
+ 'c930c72646a59161125dc03801421e5e'
+ '939cef4d4d6fa3d4124b9116a0121408')
+
+source=(
+ "${pkgname}-${pkgver}-bold.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0-Bold.otb"
+ "${pkgname}-${pkgver}-italic.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0-Italic.otb"
+ "${pkgname}-${pkgver}.otb::https://github.com/9las/uw_ttyp0/raw/master/font/UW-Ttyp0.otb"
+ "${pkgname}-${pkgver}-ttyp0::https://raw.githubusercontent.com/9las/uw_ttyp0/master/TTYP0"
+)
+package() {
+ install -dm 755 "${pkgdir}/usr/share/fonts/OTB"
+ install -m 644 "${pkgname}-${pkgver}-bold.otb" "${pkgdir}/usr/share/fonts/OTB/UW-Ttyp0-Bold.otb"
+ install -m 644 "${pkgname}-${pkgver}-italic.otb" "${pkgdir}/usr/share/fonts/OTB/UW-Ttyp0-Italic.otb"
+ install -m 644 "${pkgname}-${pkgver}.otb" "${pkgdir}/usr/share/fonts/OTB/UW-Ttyp0.otb"
+ install -Dm644 "${pkgname}-${pkgver}-ttyp0" "${pkgdir}/usr/share/licenses/$pkgname/TTYP0"
+}