summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGarlicbreadwolfs2023-11-09 21:10:48 +0900
committerGarlicbreadwolfs2023-11-09 21:10:48 +0900
commit7fda06800b5b3e10e541b19c1bc8020a65ef0466 (patch)
tree5561b93995705fe4034990df5abfc3e08a9c7605
downloadaur-7fda06800b5b3e10e541b19c1bc8020a65ef0466.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..775066489bed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-advocate-ancient
+ pkgdesc = Advocate Ancient Fonts
+ pkgver = 1.017
+ pkgrel = 1
+ url = https://github.com/GuiWonder/SourceHanToClassic
+ arch = any
+ license = custom:OFL1.1
+ source = https://github.com/GuiWonder/SourceHanToClassic/releases/download/1.017/AdvocateAncientMonoOTCs.7z
+ source = https://github.com/GuiWonder/SourceHanToClassic/releases/download/1.017/AdvocateAncientSansOTCs.7z
+ source = https://github.com/GuiWonder/SourceHanToClassic/releases/download/1.017/AdvocateAncientSerifOTCs.7z
+ sha512sums = e653b3e850c7596bface07022d2e546ea639e42a987909e1ea916e8c0c8d783d8c9478a4e0bb96f680851c533d733828be836ea786b7f75761b3bc55b2852d30
+ sha512sums = 64b49226274c09425791c45752819357b406c8cbd20e3e65c53a690ab9912468b266ab8a49ef03287d647daa4de8ef9372ff9f137ea2152a18de0d079de41f7b
+ sha512sums = f5606625e0c608dc2177ed49a2c32424fb5c18a5faae5d387f6251e5d2035d3a88db7a29711d0beff794aa9d340d3ddb4e6ab82716ccd784fa5f7bfbd89dcfde
+
+pkgname = otf-advocate-ancient
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..416b0300f1d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: garlicbreadwolfs (garlicbreadwolfs AT riseup DOT net)
+
+pkgname=otf-advocate-ancient
+_origfilename=AdvocateAncient
+_installdirname=advocate-ancient
+pkgver=1.017
+pkgrel=1
+pkgdesc='Advocate Ancient Fonts'
+arch=('any')
+url='https://github.com/GuiWonder/SourceHanToClassic'
+license=('custom:OFL1.1')
+source=(${url}/releases/download/${pkgver}/${_origfilename}MonoOTCs.7z
+ ${url}/releases/download/${pkgver}/${_origfilename}SansOTCs.7z
+ ${url}/releases/download/${pkgver}/${_origfilename}SerifOTCs.7z)
+sha512sums=('e653b3e850c7596bface07022d2e546ea639e42a987909e1ea916e8c0c8d783d8c9478a4e0bb96f680851c533d733828be836ea786b7f75761b3bc55b2852d30'
+ '64b49226274c09425791c45752819357b406c8cbd20e3e65c53a690ab9912468b266ab8a49ef03287d647daa4de8ef9372ff9f137ea2152a18de0d079de41f7b'
+ 'f5606625e0c608dc2177ed49a2c32424fb5c18a5faae5d387f6251e5d2035d3a88db7a29711d0beff794aa9d340d3ddb4e6ab82716ccd784fa5f7bfbd89dcfde')
+package() {
+ install -Dm644 *.ttc -t "$pkgdir"/usr/share/fonts/${_installdirname}/
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/${pkgname}/
+}
+