summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:39:47 +0200
committerStefan Husmann2015-06-09 00:39:47 +0200
commit1c1e5817e5c432b35adeba95c5e2638c4853960a (patch)
treecb1daa013d268ade1f0fd8989c6728a3ef6440c0
downloadaur-1c1e5817e5c432b35adeba95c5e2638c4853960a.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--otf-alegreya.install15
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b03fff76a33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-alegreya
+ pkgdesc = Alegreya fonts
+ pkgver = 1.003
+ pkgrel = 3
+ url = http://www.fontsquirrel.com/fonts/alegreya
+ install = otf-alegreya.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = otf-google-fonts-hg
+ source = http://www.fontsquirrel.com/fonts/download/alegreya
+ md5sums = SKIP
+
+pkgname = otf-alegreya
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80dd6320ab19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=otf-alegreya
+pkgver=1.003
+pkgrel=3
+pkgdesc="Alegreya fonts"
+arch=('any')
+depends=('fontconfig' 'xorg-font-utils')
+url='http://www.fontsquirrel.com/fonts/alegreya'
+source=("http://www.fontsquirrel.com/fonts/download/alegreya")
+md5sums=('SKIP')
+conflicts=('otf-google-fonts-hg')
+install=$pkgname.install
+license=('custom')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ cp -dpr --no-preserve=ownership "$srcdir"/*.otf \
+ "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 "$srcdir/SIL Open Font License.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/SIL_Open_Font_License.txt"
+}
diff --git a/otf-alegreya.install b/otf-alegreya.install
new file mode 100644
index 000000000000..1aae7e73bcb5
--- /dev/null
+++ b/otf-alegreya.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/Type1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/Type1
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}