summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Weimar2015-08-09 07:36:55 +0200
committerMarkus Weimar2015-08-09 07:36:55 +0200
commit7be62d988ce78e0cd060316076c41b13896f1568 (patch)
tree524d1c3d84376dd3e40fd0b3bb21fd1fa622042e
downloadaur-7be62d988ce78e0cd060316076c41b13896f1568.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--otf-alegreya-sans.install15
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04b8a5e41627
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-alegreya-sans
+ pkgdesc = Alegreya Sans is a humanist sans serif family with a calligraphic feeling that conveys a dynamic and varied rhythm.
+ pkgver = 1.002
+ pkgrel = 1
+ url = http://www.huertatipografica.com/en/fonts/alegreya-sans-ht
+ install = otf-alegreya-sans.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.huertatipografica.com/free_download/23
+ md5sums = 38224ce535dbc3002c6ecb1f956576d9
+
+pkgname = otf-alegreya-sans
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13ad4640cfb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Markus Weimar <mail@markusweimar.de>
+pkgname=otf-alegreya-sans
+pkgver=1.002
+pkgrel=1
+depends=('fontconfig' 'xorg-font-utils')
+pkgdesc='Alegreya Sans is a humanist sans serif family with a calligraphic feeling that conveys a dynamic and varied rhythm.'
+arch=('any')
+url='http://www.huertatipografica.com/en/fonts/alegreya-sans-ht'
+license=('custom:OFL')
+source=('http://www.huertatipografica.com/free_download/23')
+install=${pkgname}.install
+md5sums=('38224ce535dbc3002c6ecb1f956576d9')
+
+package() {
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/fonts/OTF/
+ install -m644 *.otf ${pkgdir}/usr/share/fonts/OTF/
+ install -D -m644 LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/otf-alegreya-sans.install b/otf-alegreya-sans.install
new file mode 100644
index 000000000000..724145fffa8a
--- /dev/null
+++ b/otf-alegreya-sans.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}