summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2016-06-26 18:47:54 +0900
committerorumin2016-06-26 18:47:54 +0900
commit57f4a6e84bcd10830e22c1dc826a41a1a8c5925e (patch)
tree34d319a2fc824228f2bce995b7680e09a1c5697f
downloadaur-otf-aoyanagi-reisyo-simo.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--ttf.install15
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e70b3f40f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jun 26 09:47:30 UTC 2016
+pkgbase = otf-aoyanagi-reisyo-simo
+ pkgdesc = Han old script typeface font, for Japanese
+ pkgver = 2.01
+ pkgrel = 1
+ url = http://opentype.jp/aoyagireisho.htm
+ install = ttf.install
+ arch = any
+ license = CUSTOM
+ makedepends = unzip-iconv
+ depends = fontconfig
+ depends = xorg-font-utils
+ noextract = otf-aoyanagi-reisyo-simo.zip
+ source = otf-aoyanagi-reisyo-simo.zip::http://opentype.jp/bin/aoyagireisyosimo_otf_2_01.zip
+ md5sums = fd917f3615d5eddcc06c8e6fab409781
+
+pkgname = otf-aoyanagi-reisyo-simo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91b973361516
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: orumin <dev@orum.in>
+
+pkgname=otf-aoyanagi-reisyo-simo
+pkgver=2.01
+pkgrel=1
+pkgdesc="Han old script typeface font, for Japanese"
+arch=('any')
+url="http://opentype.jp/aoyagireisho.htm"
+license=('CUSTOM')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('unzip-iconv')
+install=ttf.install
+source=("${pkgname}.zip::http://opentype.jp/bin/aoyagireisyosimo_otf_2_01.zip")
+noextract=("${pkgname}.zip")
+md5sums=('fd917f3615d5eddcc06c8e6fab409781')
+
+prepare() {
+ cd "${srcdir}"
+ unzip -Ocp932 "${pkgname}.zip"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/usr/share/fonts/aoyanagireisyosimo/"
+ install -m644 "aoyagireisyosimo_otf_2_01.otf" "${pkgdir}/usr/share/fonts/aoyanagireisyosimo/"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "フォントの使用方法.txt" "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
diff --git a/ttf.install b/ttf.install
new file mode 100644
index 000000000000..4d5d74ff35a4
--- /dev/null
+++ b/ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}