summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard König2021-03-31 20:01:06 +0200
committerLeonard König2021-03-31 20:01:06 +0200
commit864e5c57be5daeaa895e6aaa9fdf04351f09a770 (patch)
tree5bea3baa84adae601bad56a7301b436bbb709f7c
downloadaur-864e5c57be5daeaa895e6aaa9fdf04351f09a770.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rwxr-xr-xlicense.awk7
-rwxr-xr-xversion.awk3
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b0977e62726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = otf-apple-sf-mono
+ pkgdesc = Apples monospaced vairant of the San Francisco typeface family.
+ pkgver = 16.0d2e1
+ pkgrel = 1
+ url = https://developer.apple.com/fonts/
+ arch = any
+ license = custom:apple-restricted-font
+ makedepends = texlive-bin
+ makedepends = p7zip
+ source = https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg
+ source = license.awk
+ source = version.awk
+ sha256sums = fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541
+ sha256sums = cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889
+ sha256sums = 55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198
+
+pkgname = otf-apple-sf-mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a895e1415750
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leonard Janis König <ljrk@ljrk.org>
+
+pkgname='otf-apple-sf-mono'
+pkgver=16.0d2e1
+pkgrel=1
+pkgdesc='Apples monospaced vairant of the San Francisco typeface family.'
+arch=('any')
+url='https://developer.apple.com/fonts/'
+license=('custom:apple-restricted-font')
+source=('https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg'
+ 'license.awk'
+ 'version.awk')
+sha256sums=('fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541'
+ 'cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889'
+ '55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198')
+makedepends=('texlive-bin' 'p7zip')
+
+prepare() {
+ cd ${srcdir}
+ # These are dmg images, xar and cpio archives. Just use 7z.
+ 7z x -y 'SF-Mono.dmg'
+ 7z x -y 'SFMonoFonts/SF Mono Fonts.pkg'
+ 7z x -y 'Payload~'
+
+ otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ awk -f license.awk > LICENSE
+}
+
+pkgver() {
+ cd ${srcdir}
+ otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ awk -f version.awk
+}
+
+package() {
+ install -Dm655 "${srcdir}"/Library/Fonts/*.otf \
+ -t "${pkgdir}/usr/share/fonts/OTF/"
+ install -Dm644 LICENSE \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/AppleFontLicense
+}
diff --git a/license.awk b/license.awk
new file mode 100755
index 000000000000..459a4797b10d
--- /dev/null
+++ b/license.awk
@@ -0,0 +1,7 @@
+#! /usr/bin/env -S awk -f
+
+/License Description:.*/ { inlicense = 1;
+ for (i = 3; i <= NF; i++) $(i-2)=$i
+ }
+/Vendor ID:.*/ { inlicense = 0; }
+ { if (inlicense) print $0 }
diff --git a/version.awk b/version.awk
new file mode 100755
index 000000000000..414a9e9b1702
--- /dev/null
+++ b/version.awk
@@ -0,0 +1,3 @@
+#! /usr/bin/env -S awk -f
+
+/Version:.*/ { print $3 }