summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard König2021-03-31 20:22:24 +0200
committerLeonard König2021-03-31 20:22:24 +0200
commit1b7cbcb97a62ce3c2ed2cf021095379ecd31c2c0 (patch)
tree5853eb1794ffb0a1d981123b1a8d0f8ee6e35aa0
parent864e5c57be5daeaa895e6aaa9fdf04351f09a770 (diff)
downloadaur-1b7cbcb97a62ce3c2ed2cf021095379ecd31c2c0.tar.gz
Changes for Compact variant
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b0977e62726..47454bf1d67d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-pkgbase = otf-apple-sf-mono
- pkgdesc = Apples monospaced vairant of the San Francisco typeface family.
- pkgver = 16.0d2e1
+pkgbase = otf-apple-sf-compact
+ pkgdesc = Apples San Francisco typeface family. watchOS system font.
+ pkgver = 16.0d18e1
pkgrel = 1
url = https://developer.apple.com/fonts/
arch = any
license = custom:apple-restricted-font
makedepends = texlive-bin
makedepends = p7zip
- source = https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg
+ source = https://devimages-cdn.apple.com/design/resources/download/SF-Font-Compact.dmg
source = license.awk
source = version.awk
- sha256sums = fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541
+ sha256sums = 5e53392ef1bdd17b8daf940745bcc85ad9f01c975eaf1e812a5c0a2d67897ec5
sha256sums = cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889
sha256sums = 55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198
-pkgname = otf-apple-sf-mono
+pkgname = otf-apple-sf-compact
diff --git a/PKGBUILD b/PKGBUILD
index a895e1415750..14d75ab714d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Leonard Janis König <ljrk@ljrk.org>
-pkgname='otf-apple-sf-mono'
-pkgver=16.0d2e1
+pkgname='otf-apple-sf-compact'
+pkgver=16.0d18e1
pkgrel=1
-pkgdesc='Apples monospaced vairant of the San Francisco typeface family.'
+pkgdesc='Apples San Francisco typeface family. watchOS system font.'
arch=('any')
url='https://developer.apple.com/fonts/'
license=('custom:apple-restricted-font')
-source=('https://devimages-cdn.apple.com/design/resources/download/SF-Mono.dmg'
+source=('https://devimages-cdn.apple.com/design/resources/download/SF-Font-Compact.dmg'
'license.awk'
'version.awk')
-sha256sums=('fc0beba1460fbe0f1f6d7c0f1eff6e09dd9cd996a24595f47dcb332614ecd541'
+sha256sums=('5e53392ef1bdd17b8daf940745bcc85ad9f01c975eaf1e812a5c0a2d67897ec5'
'cd45a6edaa3829837b090a5a18d3c906816931e7a779b33b6ada23b49b5a5889'
'55a4e9e108e50b07481044fad445636e502f2d95d7e8964e1d4cda3e9618b198')
makedepends=('texlive-bin' 'p7zip')
@@ -18,17 +18,17 @@ makedepends=('texlive-bin' 'p7zip')
prepare() {
cd ${srcdir}
# These are dmg images, xar and cpio archives. Just use 7z.
- 7z x -y 'SF-Mono.dmg'
- 7z x -y 'SFMonoFonts/SF Mono Fonts.pkg'
+ 7z x -y 'SF-Font-Compact.dmg'
+ 7z x -y 'SanFranciscoCompact/San Francisco Compact.pkg'
7z x -y 'Payload~'
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Compact-Display-Regular.otf | \
awk -f license.awk > LICENSE
}
pkgver() {
cd ${srcdir}
- otfinfo -i Library/Fonts/SF-Mono-BoldItalic.otf | \
+ otfinfo -i Library/Fonts/SF-Compact-Display-Regular.otf | \
awk -f version.awk
}