summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadow532015-06-11 14:06:01 -0700
committerShadow532015-06-11 14:06:01 -0700
commit0dac1ad635f061bdcb16c3f27d7b546976797933 (patch)
treed7521b285713a1cfc054abbc6d57b4c701bd0d87
downloadaur-0dac1ad635f061bdcb16c3f27d7b546976797933.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--otf-auretech.install15
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2971e1912c6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = otf-auretech
+ pkgdesc = Custom font based on Star Wars Galactic Basic (Aurebesh/Aurek-Besh) by Tycho_Ordo on theforce.net - Technumbers version
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://boards.theforce.net/threads/new-aurebesh-font.50009464
+ install = otf-auretech.install
+ arch = any
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://www.dropbox.com/s/jsdrwvldw71my96/AureTech.otf
+ md5sums = bb97e49bbe9c2a6d32ae96d8458a1ae5
+
+pkgname = otf-auretech
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72d1b115f4b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=otf-auretech
+pkgver=1.0
+pkgrel=1
+pkgdesc="Custom font based on Star Wars Galactic Basic (Aurebesh/Aurek-Besh) by Tycho_Ordo on theforce.net - Technumbers version"
+arch=(any)
+url=("http://boards.theforce.net/threads/new-aurebesh-font.50009464")
+depends=(fontconfig xorg-font-utils)
+source=("https://www.dropbox.com/s/jsdrwvldw71my96/AureTech.otf")
+md5sums=("bb97e49bbe9c2a6d32ae96d8458a1ae5")
+install=$pkgname.install
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 "$srcdir/"*.otf "$pkgdir/usr/share/fonts/OTF/"
+}
diff --git a/otf-auretech.install b/otf-auretech.install
new file mode 100644
index 000000000000..fe5c52fe1795
--- /dev/null
+++ b/otf-auretech.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}