summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2015-07-28 09:11:26 +0300
committerCaleb Maclennan2015-07-28 09:18:36 +0300
commit02af8a10400d480441668e1c24bf32c9306a6ffa (patch)
tree07e552b77aa71e85a4e1e7154ad30bbc55bfd0a3
downloadaur-02af8a10400d480441668e1c24bf32c9306a6ffa.tar.gz
initial package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ad17211ce57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = otf-bravura
+ pkgdesc = an SMuFL compliant music font designed by Daniel Spreadbury at Steinberg
+ pkgver = 1.18
+ pkgrel = 1
+ url = http://www.smufl.org/fonts/
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.smufl.org/files/bravura-1.18.zip
+ sha256sums = abf55d5e01db584c9a00a7395bfc64b667e1b35240a7d188e8eb393a8fbb51b6
+
+pkgname = otf-bravura
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc6e0cc35674
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=otf-bravura
+pkgver=1.18
+pkgrel=1
+pkgdesc="an SMuFL compliant music font designed by Daniel Spreadbury at Steinberg"
+arch=('any')
+url="http://www.smufl.org/fonts/"
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://www.smufl.org/files/bravura-${pkgver}.zip")
+sha256sums=('abf55d5e01db584c9a00a7395bfc64b667e1b35240a7d188e8eb393a8fbb51b6')
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+package() {
+ cd "${srcdir}"
+ find . -name '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ install -Dm644 "OFL.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+