summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-08-04 20:44:30 +0300
committerGordonGR2015-08-04 20:44:30 +0300
commit2371a7e4446d769505a25095d913d1241da069bc (patch)
tree574d4375923de1c2fc9d6ec2fc73142a81f6a35a
downloadaur-2371a7e4446d769505a25095d913d1241da069bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--cm-unicode.install15
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32402d91bde7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-cm-unicode
+ pkgdesc = A font family converted from D. Knuth's Computer Modern metafont.
+ pkgver = 0.7.0
+ pkgrel = 2
+ url = http://canopus.iacp.dvo.ru/~panov/cm-unicode/
+ install = cm-unicode.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://downloads.sourceforge.net/cm-unicode/cm-unicode-0.7.0-otf.tar.xz
+ md5sums = 8503cc1316103d97a668a9efa71d0e3c
+
+pkgname = otf-cm-unicode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..466f20622d2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+
+pkgname=otf-cm-unicode
+_pkgname=cm-unicode
+pkgver=0.7.0
+pkgrel=2
+pkgdesc="A font family converted from D. Knuth's Computer Modern metafont."
+arch=('any')
+url="http://canopus.iacp.dvo.ru/~panov/cm-unicode/"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=cm-unicode.install
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver-otf.tar.xz")
+md5sums=('8503cc1316103d97a668a9efa71d0e3c')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 *.otf "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL.txt"
+}
diff --git a/cm-unicode.install b/cm-unicode.install
new file mode 100644
index 000000000000..2158e59eac20
--- /dev/null
+++ b/cm-unicode.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}