summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshymad2018-07-12 14:45:46 +0200
committerAshymad2018-07-12 14:45:46 +0200
commit6e45c1b25f0dc8489618b31867a976f4a454e60b (patch)
tree93e73b8c9ab18170932cb3db5fe72c28ed054596
parent93609ec98e99939b0dfe28a2b0928443fa173048 (diff)
downloadaur-6e45c1b25f0dc8489618b31867a976f4a454e60b.tar.gz
Better version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 121452c51dcc..55c26079f83c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,14 @@
pkgbase = otf-code-new-roman
pkgdesc = Monospaced font aimed for use in programming environments
- pkgver = 2.0
- pkgrel = 3
+ pkgver = 2.1
+ pkgrel = 1
url = http://fb.com/Code.New.Roman
arch = any
license = custom
depends = fontconfig
depends = xorg-font-utils
- source = CodeNewRoman-Bold.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Bold.otf
- source = CodeNewRoman-Italic.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Italic.otf
- source = CodeNewRoman-Regular.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Regular.otf
- source = https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/license.txt
- sha256sums = 42d7dd94691a24bc3aece8489c24c8050250b320a6ec1d250115dafbfa0314f3
- sha256sums = 3d2f971aa1829cca3df46cdf9f4385c57afba9e507b1821ba64d73dc1cc7ec08
- sha256sums = dfa19137778f3af70380f68452dc1c2ab364597cddda80a10819e46e35c1b984
- sha256sums = bd5d5113498de3036d9d5c9c11d0f744cd79d31146f27ef6f7bcf8877acfdd94
+ source = https://fontain.org/code-new-roman/export/otf/code-new-roman.otf.zip
+ sha256sums = 88e0fb4a3683e50e14d52722924b7ea7d0893910c39f65bf071ae100f0b75bf7
pkgname = otf-code-new-roman
diff --git a/PKGBUILD b/PKGBUILD
index a9c951aeeae4..9d922012c343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,20 @@
# Maintainer: Ashymad <czilukim@o2.pl>
pkgname="otf-code-new-roman"
-pkgver="2.0"
-pkgrel=3
+pkgver="2.1"
+pkgrel=1
pkgdesc='Monospaced font aimed for use in programming environments'
arch=('any')
url='http://fb.com/Code.New.Roman'
license=('custom')
depends=(fontconfig xorg-font-utils)
-source=('CodeNewRoman-Bold.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Bold.otf'
- 'CodeNewRoman-Italic.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Italic.otf'
- 'CodeNewRoman-Regular.ttf::https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/Code%20New%20Roman-Regular.otf'
- 'https://github.com/chrissimpkins/codeface/raw/master/fonts/code-new-roman/license.txt')
+source=('https://fontain.org/code-new-roman/export/otf/code-new-roman.otf.zip')
-sha256sums=('42d7dd94691a24bc3aece8489c24c8050250b320a6ec1d250115dafbfa0314f3'
- '3d2f971aa1829cca3df46cdf9f4385c57afba9e507b1821ba64d73dc1cc7ec08'
- 'dfa19137778f3af70380f68452dc1c2ab364597cddda80a10819e46e35c1b984'
- 'bd5d5113498de3036d9d5c9c11d0f744cd79d31146f27ef6f7bcf8877acfdd94')
+sha256sums=('88e0fb4a3683e50e14d52722924b7ea7d0893910c39f65bf071ae100f0b75bf7')
+
package() {
cd "$srcdir"
- mkdir -p "$pkgdir/usr/share/fonts/TTF/"
- install -Dm644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
- install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ mkdir -p "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 *.otf "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}