summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLennard Hofmann2020-07-14 14:39:52 +0200
committerLennard Hofmann2020-07-14 15:13:38 +0200
commit7c7bd52b939173280335e56a21ee40e362b9a4aa (patch)
treef25e31b868d22af4f6fcde26897736bb6121a2e7
parent40bbce0cbb3970767920e8b50f0acc58122fd170 (diff)
downloadaur-7c7bd52b939173280335e56a21ee40e362b9a4aa.tar.gz
Adopt package; cleanup
- Change description so that it is not self-referencing and includes the word “font” - Update URL - OFL is treated as a common license, see https://wiki.archlinux.org/index.php/PKGBUILD#license - Remove dependencies and install script, see https://wiki.archlinux.org/index.php/Font_package_guidelines - Install real license not FAQ - Install license from zip archive. No need to pull it from GitHub. - Install FontLog - Use sha256 instead of less secure md5
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
-rw-r--r--otf-cooper-hewitt.install15
3 files changed, 23 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 573ede7eca21..7629eadca3dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,12 @@
pkgbase = otf-cooper-hewitt
- pkgdesc = Cooper Hewitt font
- pkgver = 1.0
- pkgrel = 1
- url = http://www.cooperhewitt.org/colophon/cooper-hewitt-the-typeface-by-chester-jenkins/
- install = otf-cooper-hewitt.install
+ pkgdesc = sans-serif font by Chester Jenkins
+ pkgver = 1.000
+ pkgrel = 2
+ url = https://www.cooperhewitt.org/open-source-at-cooper-hewitt/cooper-hewitt-the-typeface-by-chester-jenkins/
arch = any
- license = custom
- depends = fontconfig
- depends = xorg-font-utils
- source = http://uh8yh30l48rpize52xh0q1o6i.wpengine.netdna-cdn.com/wp-content/uploads/fonts/CooperHewitt-OTF-public.zip
- source = LICENSE::https://raw.githubusercontent.com/cooperhewitt/cooperhewitt-typeface/master/files/-OFL-FAQ.txt
- source = otf-cooper-hewitt.install
- md5sums = cbff2bac99d77efd80f9b17689bcfc8c
- md5sums = ecad149092c844fd28c1b727871748b6
- md5sums = da4ec4807849dfb5ad3aa5896912cfe6
+ license = OFL
+ source = otf-cooper-hewitt-1.000.zip::https://uh8yh30l48rpize52xh0q1o6i-wpengine.netdna-ssl.com/wp-content/uploads/fonts/CooperHewitt-OTF-public.zip
+ sha256sums = df5b0869296092fca85742a6295db8bbdedb4e1e19ecaafd195bbabd1ef22d4e
pkgname = otf-cooper-hewitt
diff --git a/PKGBUILD b/PKGBUILD
index aca252b78eb5..668dc95847ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,20 @@
-# Maintainer: Foppe Hemminga <foppe@foppe.org>
-
+# Maintainer: Lennard Hofmann <lennard dot hofmann at web dot de>
+# Contributor: Foppe Hemminga <foppe@foppe.org>
pkgname=otf-cooper-hewitt
-pkgver=1.0
-pkgrel=1
-pkgdesc="Cooper Hewitt font"
-url="http://www.cooperhewitt.org/colophon/cooper-hewitt-the-typeface-by-chester-jenkins/"
+pkgver=1.000
+pkgrel=2
+pkgdesc="sans-serif font by Chester Jenkins"
+url="https://www.cooperhewitt.org/open-source-at-cooper-hewitt/cooper-hewitt-the-typeface-by-chester-jenkins/"
arch=(any)
-license=('custom')
-depends=(fontconfig xorg-font-utils)
-source=("http://uh8yh30l48rpize52xh0q1o6i.wpengine.netdna-cdn.com/wp-content/uploads/fonts/CooperHewitt-OTF-public.zip"
-"LICENSE::https://raw.githubusercontent.com/cooperhewitt/cooperhewitt-typeface/master/files/-OFL-FAQ.txt"
-"otf-cooper-hewitt.install")
-md5sums=("cbff2bac99d77efd80f9b17689bcfc8c"
- "ecad149092c844fd28c1b727871748b6"
- "da4ec4807849dfb5ad3aa5896912cfe6")
-install=$pkgname.install
+license=('OFL')
+source=(
+"$pkgname-$pkgver.zip::https://uh8yh30l48rpize52xh0q1o6i-wpengine.netdna-ssl.com/wp-content/uploads/fonts/CooperHewitt-OTF-public.zip"
+)
+sha256sums=('df5b0869296092fca85742a6295db8bbdedb4e1e19ecaafd195bbabd1ef22d4e')
package() {
- install -d "$pkgdir/usr/share/fonts/OTF"
- install -m644 "$srcdir/CooperHewitt-OTF-public/"*.otf "$pkgdir/usr/share/fonts/OTF/"
- install -Dm644 "${srcdir}/LICENSE" ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-} \ No newline at end of file
+ cd $srcdir/CooperHewitt-OTF-public
+ install -Dm644 *.otf -t "$pkgdir/usr/share/fonts/$pkgname/"
+ install -Dm644 -- -CooperHewitt-OFL-201406.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -- -CooperHewitt-FontLog.txt "$pkgdir/usr/share/doc/$pkgname/FontLog"
+}
diff --git a/otf-cooper-hewitt.install b/otf-cooper-hewitt.install
deleted file mode 100644
index 190331d218ec..000000000000
--- a/otf-cooper-hewitt.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- echo -n "Updating font cache... "
- fc-cache >/dev/null -f
- mkfontscale /usr/share/fonts/OTF
- mkfontdir /usr/share/fonts/OTF
- echo done
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-} \ No newline at end of file