summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmeGa2015-07-08 02:15:25 -0500
committerOmeGa2015-07-08 02:15:25 -0500
commit971644f6db881b75795c3640202fc204e9fdb22b (patch)
treee019e24d0ce2be703388444c97589f01f21e44b1
downloadaur-971644f6db881b75795c3640202fc204e9fdb22b.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--otf.install16
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..535cd9553025
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-eb-garamond
+ pkgdesc = Digitization of the Garamond shown on the Egenolff-Berner specimen.
+ pkgver = 0.016
+ pkgrel = 2
+ url = http://www.georgduffner.at/ebgaramond/
+ install = otf.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://bitbucket.org/georgd/eb-garamond/downloads/EBGaramond-0.016.zip
+ sha1sums = c88ce0551eca9d03954d1cbce54a83d4a4d2b1e2
+
+pkgname = otf-eb-garamond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8edf1ab812ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: OmeGa <omega [U+0040] mailoo [.] org>
+
+pkgname=otf-eb-garamond
+pkgver=0.016
+pkgrel=2
+pkgdesc="Digitization of the Garamond shown on the Egenolff-Berner specimen."
+arch=('any')
+url="http://www.georgduffner.at/ebgaramond/"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+install=otf.install
+source=(https://bitbucket.org/georgd/eb-garamond/downloads/EBGaramond-$pkgver.zip)
+sha1sums=('c88ce0551eca9d03954d1cbce54a83d4a4d2b1e2')
+
+package() {
+ cd "$srcdir/EBGaramond-$pkgver"
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 otf/*.otf "$pkgdir/usr/share/fonts/OTF/"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..53a54dd2bba8
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+