summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2018-08-04 17:27:35 +0300
committerCaleb Maclennan2018-08-04 17:27:35 +0300
commit2abc6d169bd6ad0157b402aad414f3fcceb9223d (patch)
treec315bd72f650cc8711c46f83928951bbb8ed4cfe
parentc52d4d5ddef825a6a8dc68796835f5abfbaeb9c0 (diff)
downloadaur-2abc6d169bd6ad0157b402aad414f3fcceb9223d.tar.gz
Refactor without infinity bundle components
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 16 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fbd64ebcff6..9a23cd3bd0c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
# Generated by mksrcinfo v8
-# Wed Sep 6 15:57:43 UTC 2017
-pkgbase = otf-erewhon-ibx
+# Sat Aug 4 14:27:13 UTC 2018
+pkgbase = otf-erewhon
pkgdesc = Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd.
pkgver = 1.08
pkgrel = 1
url = http://www.ctan.org/tex-archive/fonts/erewhon
arch = any
- groups = infinality-bundle-fonts-extra
license = custom:OFL
depends = fontconfig
+ conflicts = otf-erewhon-ibx
source = http://mirrors.ctan.org/fonts/erewhon.zip
- source = 45-erewhon.conf
- source = 90-non-tt-erewhon.conf
- sha1sums = e93a1b90089e1b9d4545c34f5209a237f0991c64
- sha1sums = 1648a48e6f02f7da610d6544eede2083fbc50cb9
- sha1sums = 37c4c88d165b74896f59d940aaebb275253a5c0e
+ sha256sums = d1821e2d1fcf16192fd2e32b29b09ae72bed810ea67b33c92d8f285cb4d75748
-pkgname = otf-erewhon-ibx
+pkgname = otf-erewhon
diff --git a/PKGBUILD b/PKGBUILD
index 3f74f2c1ec25..b9cb91190f06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,21 @@
-# Maintainer: bohoomil <@zoho.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: bohoomil <bohoomil@zoho.com>
-pkgname=otf-erewhon-ibx
+_ffname=erewhon
+pkgname=otf-${_ffname}
pkgver=1.08
pkgrel=1
depends=('fontconfig')
pkgdesc="Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd."
-url="http://www.ctan.org/tex-archive/fonts/erewhon"
+url="http://www.ctan.org/tex-archive/fonts/${_ffname}"
arch=('any')
-groups=('infinality-bundle-fonts-extra')
license=('custom:OFL')
-source=(http://mirrors.ctan.org/fonts/erewhon.zip
- 45-erewhon.conf
- 90-non-tt-erewhon.conf)
-sha1sums=('e93a1b90089e1b9d4545c34f5209a237f0991c64'
- '1648a48e6f02f7da610d6544eede2083fbc50cb9'
- '37c4c88d165b74896f59d940aaebb275253a5c0e')
+conflicts=("${pkgname}-ibx")
+source=("http://mirrors.ctan.org/fonts/erewhon.zip")
+sha256sums=('d1821e2d1fcf16192fd2e32b29b09ae72bed810ea67b33c92d8f285cb4d75748')
package(){
- cd erewhon
-
- install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
- install -m644 doc/"OFL.txt" \
- "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
-
- install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
- install -m644 opentype/*.otf "${pkgdir}"/usr/share/fonts/"${pkgname}"
-
- install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
- install -m755 -d "${pkgdir}"/etc/fonts/conf.d
- install -m644 ../45-erewhon.conf \
- "${pkgdir}"/etc/fonts/conf.avail/45-erewhon.conf
- install -m644 ../90-non-tt-erewhon.conf \
- "${pkgdir}"/etc/fonts/conf.avail/90-non-tt-erewhon.conf
-
- cd "${pkgdir}"/etc/fonts/conf.d
- ln -s ../conf.avail/45-erewhon.conf .
- ln -s ../conf.avail/90-non-tt-erewhon.conf .
+ cd "${_ffname}"
+ install -Dm0644 doc/OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm0644 opentype/*.otf -t "${pkgdir}/usr/share/fonts/OTF/"
}