summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-09-06 11:57:48 -0400
committerSolomon Choina2017-09-06 11:57:48 -0400
commitc52d4d5ddef825a6a8dc68796835f5abfbaeb9c0 (patch)
tree541b1b464a9518f1e242c0544e69c02d59639f9d
downloadaur-c52d4d5ddef825a6a8dc68796835f5abfbaeb9c0.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--45-erewhon.conf12
-rw-r--r--90-non-tt-erewhon.conf23
-rw-r--r--PKGBUILD39
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fbd64ebcff6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Sep 6 15:57:43 UTC 2017
+pkgbase = otf-erewhon-ibx
+ pkgdesc = Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd.
+ pkgver = 1.08
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/fonts/erewhon
+ arch = any
+ groups = infinality-bundle-fonts-extra
+ license = custom:OFL
+ depends = fontconfig
+ source = http://mirrors.ctan.org/fonts/erewhon.zip
+ source = 45-erewhon.conf
+ source = 90-non-tt-erewhon.conf
+ sha1sums = e93a1b90089e1b9d4545c34f5209a237f0991c64
+ sha1sums = 1648a48e6f02f7da610d6544eede2083fbc50cb9
+ sha1sums = 37c4c88d165b74896f59d940aaebb275253a5c0e
+
+pkgname = otf-erewhon-ibx
+
diff --git a/45-erewhon.conf b/45-erewhon.conf
new file mode 100644
index 000000000000..80c7b3894d0a
--- /dev/null
+++ b/45-erewhon.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Erewhon</family>
+ <default>
+ <family>serif</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-non-tt-erewhon.conf b/90-non-tt-erewhon.conf
new file mode 100644
index 000000000000..3ebc348cdd76
--- /dev/null
+++ b/90-non-tt-erewhon.conf
@@ -0,0 +1,23 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="family">
+ <string>Erewhon</string>
+ </test>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f74f2c1ec25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=otf-erewhon-ibx
+pkgver=1.08
+pkgrel=1
+depends=('fontconfig')
+pkgdesc="Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd."
+url="http://www.ctan.org/tex-archive/fonts/erewhon"
+arch=('any')
+groups=('infinality-bundle-fonts-extra')
+license=('custom:OFL')
+source=(http://mirrors.ctan.org/fonts/erewhon.zip
+ 45-erewhon.conf
+ 90-non-tt-erewhon.conf)
+sha1sums=('e93a1b90089e1b9d4545c34f5209a237f0991c64'
+ '1648a48e6f02f7da610d6544eede2083fbc50cb9'
+ '37c4c88d165b74896f59d940aaebb275253a5c0e')
+
+package(){
+ cd erewhon
+
+ install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ install -m644 doc/"OFL.txt" \
+ "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
+
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 opentype/*.otf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 ../45-erewhon.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-erewhon.conf
+ install -m644 ../90-non-tt-erewhon.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-non-tt-erewhon.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-erewhon.conf .
+ ln -s ../conf.avail/90-non-tt-erewhon.conf .
+}