summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-13 21:54:39 +0300
committerCaleb Maclennan2020-03-13 21:54:39 +0300
commit3b2c161c9187833f9028eaaadf39b49e23303515 (patch)
treef9c0d74c949ce7596da50dedae38b5ad11684bf6
parentc52d4d5ddef825a6a8dc68796835f5abfbaeb9c0 (diff)
downloadaur-3b2c161c9187833f9028eaaadf39b49e23303515.tar.gz
Adopt, remove obsolete dependencies, update to 1.102, package docs
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 27 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fbd64ebcff6..a1ce0454a48e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Sep 6 15:57:43 UTC 2017
pkgbase = otf-erewhon-ibx
- pkgdesc = Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd.
- pkgver = 1.08
+ pkgdesc = Erewhon is based on the Heuristica family, which is based in turn on Utopia
+ pkgver = 1.102
pkgrel = 1
url = http://www.ctan.org/tex-archive/fonts/erewhon
arch = any
groups = infinality-bundle-fonts-extra
- license = custom:OFL
- depends = fontconfig
+ license = OFL
source = http://mirrors.ctan.org/fonts/erewhon.zip
source = 45-erewhon.conf
source = 90-non-tt-erewhon.conf
- sha1sums = e93a1b90089e1b9d4545c34f5209a237f0991c64
- sha1sums = 1648a48e6f02f7da610d6544eede2083fbc50cb9
- sha1sums = 37c4c88d165b74896f59d940aaebb275253a5c0e
+ sha256sums = c5785f1729593185b3eed46d8ff8a8c4f3b2145df76926d2d1e324fa15a7e66a
+ sha256sums = a122f645314ed9e69f55ec77aef6956e4471418baa098f232165d2fbf130aa75
+ sha256sums = 74a318013024001702310420fa07e06f9cbf4d4db936a76d1be981c98662c1ca
pkgname = otf-erewhon-ibx
diff --git a/PKGBUILD b/PKGBUILD
index 3f74f2c1ec25..a96a27c20a0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,29 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Maintainer: bohoomil <@zoho.com>
+_ctan=erewhon
pkgname=otf-erewhon-ibx
-pkgver=1.08
+pkgver=1.102
pkgrel=1
-depends=('fontconfig')
-pkgdesc="Erewhon is based on the Heuristica family, which is based in turn on Utopia. The size is 6% smaller than Heuristica, matching that of UtopiaStd."
-url="http://www.ctan.org/tex-archive/fonts/erewhon"
+pkgdesc='Erewhon is based on the Heuristica family, which is based in turn on Utopia'
+url="http://www.ctan.org/tex-archive/fonts/$_ctan"
arch=('any')
groups=('infinality-bundle-fonts-extra')
-license=('custom:OFL')
-source=(http://mirrors.ctan.org/fonts/erewhon.zip
- 45-erewhon.conf
- 90-non-tt-erewhon.conf)
-sha1sums=('e93a1b90089e1b9d4545c34f5209a237f0991c64'
- '1648a48e6f02f7da610d6544eede2083fbc50cb9'
- '37c4c88d165b74896f59d940aaebb275253a5c0e')
+license=('OFL')
+source=(http://mirrors.ctan.org/fonts/$_ctan.zip
+ 45-$_ctan.conf
+ 90-non-tt-$_ctan.conf)
+sha256sums=('c5785f1729593185b3eed46d8ff8a8c4f3b2145df76926d2d1e324fa15a7e66a'
+ 'a122f645314ed9e69f55ec77aef6956e4471418baa098f232165d2fbf130aa75'
+ '74a318013024001702310420fa07e06f9cbf4d4db936a76d1be981c98662c1ca')
-package(){
- cd erewhon
-
- install -m755 -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
- install -m644 doc/"OFL.txt" \
- "${pkgdir}"/usr/share/licenses/"${pkgname}"/COPYING
-
- install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
- install -m644 opentype/*.otf "${pkgdir}"/usr/share/fonts/"${pkgname}"
-
- install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
- install -m755 -d "${pkgdir}"/etc/fonts/conf.d
- install -m644 ../45-erewhon.conf \
- "${pkgdir}"/etc/fonts/conf.avail/45-erewhon.conf
- install -m644 ../90-non-tt-erewhon.conf \
- "${pkgdir}"/etc/fonts/conf.avail/90-non-tt-erewhon.conf
-
- cd "${pkgdir}"/etc/fonts/conf.d
- ln -s ../conf.avail/45-erewhon.conf .
- ln -s ../conf.avail/90-non-tt-erewhon.conf .
+package() {
+ cd $_ctan
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/$pkgname/" opentype/*.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" doc/OFL*.txt
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" doc/{FontLog.txt,$_ctan-doc.pdf}
+ install -Dm644 -t "$pkgdir/etc/fonts/conf.avail/" ../[0-9]*-$_ctan.conf
+ install -dm644 "$pkgdir/etc/fonts/conf.d"
+ cd "$pkgdir/etc/fonts/conf.d"
+ ln -s ../conf.avail/*.conf .
}