summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2016-08-16 21:53:10 +0800
committerIru Cai2016-08-16 21:53:10 +0800
commita408ef7a2c6125ab90b6e7f36532b55d16f19d21 (patch)
treef0eb9e720c8d1e228a8c9c92ee7991b12d1e7b72
downloadaur-a408ef7a2c6125ab90b6e7f36532b55d16f19d21.tar.gz
otf-fandol: initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--otf-fandol.install13
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec2ac68711a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Aug 16 13:52:46 UTC 2016
+pkgbase = otf-fandol
+ pkgdesc = Four basic fonts for Chinese typesetting: Song, Hei, Kai, Fang
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://www.ctan.org/pkg/fandol
+ install = otf-fandol.install
+ arch = any
+ license = GPL3
+ makedepends = unzip
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://mirrors.ctan.org/fonts/fandol.zip
+ md5sums = a9952cb42499179e110550d867219da0
+
+pkgname = otf-fandol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dca72313099e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Iru Cai <mytbk920423@gmail.com>
+
+pkgname=otf-fandol
+pkgver=0.3
+pkgrel=1
+pkgdesc='Four basic fonts for Chinese typesetting: Song, Hei, Kai, Fang'
+license=('GPL3')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('unzip')
+arch=('any')
+url='http://www.ctan.org/pkg/fandol'
+source=('http://mirrors.ctan.org/fonts/fandol.zip')
+install=$pkgname.install
+md5sums=('a9952cb42499179e110550d867219da0')
+
+package() {
+ cd "$srcdir"
+ install -d "$pkgdir"/usr/share{/fonts/OTF,/licenses/$pkgname}
+ cp fandol/*.otf "$pkgdir/usr/share/fonts/OTF"
+ cp fandol/COPYING "$pkgdir/usr/share/licenses/$pkgname"
+}
+
diff --git a/otf-fandol.install b/otf-fandol.install
new file mode 100644
index 000000000000..4b77955a6a4f
--- /dev/null
+++ b/otf-fandol.install
@@ -0,0 +1,13 @@
+post_install()
+{
+ echo -n "Updating font cache..."
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade()
+{
+ post_install
+}