summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Lenzen2015-09-18 10:47:22 +0600
committerMike Lenzen2015-09-18 10:47:22 +0600
commit1e8d30e29dd01468fa3c1456e5645851f4ab22a6 (patch)
tree32b14cb953536e3fccbe349b5daf2d514aa513b9
downloadaur-1e8d30e29dd01468fa3c1456e5645851f4ab22a6.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--otf-fanwood-git.install16
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35a0f974f79b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-fanwood-git
+ pkgdesc = A serif based on the work of a famous Czech-American type designer of yesteryear.
+ pkgver = r1.cbaaed9
+ pkgrel = 1
+ url = https://github.com/theleagueof/fanwood
+ install = otf-fanwood-git.install
+ arch = any
+ license = custom:"OFL"
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = otf-fanwood-git::git://github.com/theleagueof/fanwood
+ md5sums = SKIP
+
+pkgname = otf-fanwood-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3769992a5766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mike Lenzen <lenzenmi@gmail.com>
+pkgname=otf-fanwood-git
+pkgver=r1.cbaaed9
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgrel=1
+pkgdesc="A serif based on the work of a famous Czech-American type designer of yesteryear."
+url=('https://github.com/theleagueof/fanwood')
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+source=("$pkgname::git://github.com/theleagueof/fanwood")
+install=$pkgname.install
+license=('custom:"OFL"')
+md5sums=('SKIP')
+
+package() {
+#FONT
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 "$srcdir/$pkgname/"*.otf "$pkgdir/usr/share/fonts/OTF/"
+#LICENSE
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 "$srcdir/$pkgname/Open Font License.markdown" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/otf-fanwood-git.install b/otf-fanwood-git.install
new file mode 100644
index 000000000000..62723c7717a9
--- /dev/null
+++ b/otf-fanwood-git.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+