summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:21:19 -0700
committerGavin Lloyd2015-06-09 17:21:19 -0700
commite450fd524cb28eebda560aef71f29672d1169ad4 (patch)
treef75259a230a254fb9b9727e024c525ebbecfc2e3
downloadaur-e450fd524cb28eebda560aef71f29672d1169ad4.tar.gz
Init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--otf-fifthleg.install18
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db5cd25fb3d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-fifthleg
+ pkgdesc = Font used for openSUSE-branded material
+ pkgver = 0.6
+ pkgrel = 5
+ url = http://jimmac.musichall.cz/log/?p=440
+ install = otf-fifthleg.install
+ arch = i686
+ arch = x86_64
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://api.opensuse.org/public/source/openSUSE:Factory/fifth-leg-font/opensuse-font-fifth-leg-0.6.tar.bz2
+ md5sums = 5a9852e078b4c9ccd8fe5c472bba1184
+
+pkgname = otf-fifthleg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e08507d9fdd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Chad Davis <archlinux@davtek.com>
+
+pkgname=otf-fifthleg
+pkgver=0.6
+pkgrel=5
+pkgdesc='Font used for openSUSE-branded material'
+arch=('i686' 'x86_64')
+license=('custom:OFL')
+url='http://jimmac.musichall.cz/log/?p=440'
+depends=('fontconfig' 'xorg-font-utils')
+source=("https://api.opensuse.org/public/source/openSUSE:Factory/fifth-leg-font/opensuse-font-fifth-leg-$pkgver.tar.bz2")
+md5sums=('5a9852e078b4c9ccd8fe5c472bba1184')
+install=$pkgname.install
+
+package() {
+ install -d $pkgdir/usr/share/fonts/OTF/
+ install -d $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 *.otf $pkgdir/usr/share/fonts/OTF/
+ install -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/
+}
diff --git a/otf-fifthleg.install b/otf-fifthleg.install
new file mode 100644
index 000000000000..8de353a0501f
--- /dev/null
+++ b/otf-fifthleg.install
@@ -0,0 +1,18 @@
+post_install() {
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*