summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-08-04 20:39:21 +0300
committerGordonGR2015-08-04 20:39:21 +0300
commitff397eaefd1bfb2b0f1145a39ffc79c1691187bd (patch)
treea59ff511c26952e629e0abb62442d33877b1a8d3
downloadaur-ff397eaefd1bfb2b0f1145a39ffc79c1691187bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD34
-rw-r--r--otf-gfs-majuscule.install13
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58510b7370b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = otf-gfs-majuscule
+ pkgdesc = Open Font Majuscule typefaces, provided by the Greek Font Society
+ pkgver = 20110730
+ pkgrel = 1
+ url = http://www.greekfontsociety.gr/pages/gr_typefaces1.html
+ install = otf-gfs-majuscule.install
+ arch = any
+ license = custom:OTF
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.greekfontsociety.gr/GFS_AMBROSIA.zip
+ source = http://www.greekfontsociety.gr/GFS_FLEISCHMAN.zip
+ source = http://www.greekfontsociety.gr/GFS_EUSTACE.zip
+ source = http://www.greekfontsociety.gr/GFS_NICEFORE.zip
+ source = http://www.greekfontsociety.gr/GFS_JACKSON.zip
+ source = http://www.greekfontsociety.gr/GFS_GARALDUS.zip
+ source = http://www.greekfontsociety.gr/GFS_IGNACIO.zip
+ md5sums = 891a6e880ca0ef06223eedfab7c0e035
+ md5sums = adcb048bdca18dd243c0337bdb0c5ecd
+ md5sums = b54eea11af83c569b861a17800fb1945
+ md5sums = 02fcaf05448bb0df6696567975014132
+ md5sums = 73d235051292e23bc807c71d8c951e6b
+ md5sums = 7638996769c9162f0d8b8885c18af68f
+ md5sums = ec397b1199ca79404adec355eeb5c163
+
+pkgname = otf-gfs-majuscule
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..314cf95795a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Angel Sartonev <a.sartonev at gmail dot com>
+
+pkgname=otf-gfs-majuscule
+pkgver=20110730
+pkgrel=1
+pkgdesc='Open Font Majuscule typefaces, provided by the Greek Font Society'
+arch=(any)
+url='http://www.greekfontsociety.gr/pages/gr_typefaces1.html'
+license=('custom:OTF')
+depends=('fontconfig' 'xorg-font-utils')
+install='otf-gfs-majuscule.install'
+source=('http://www.greekfontsociety.gr/GFS_AMBROSIA.zip'
+ 'http://www.greekfontsociety.gr/GFS_FLEISCHMAN.zip'
+ 'http://www.greekfontsociety.gr/GFS_EUSTACE.zip'
+ 'http://www.greekfontsociety.gr/GFS_NICEFORE.zip'
+ 'http://www.greekfontsociety.gr/GFS_JACKSON.zip'
+ 'http://www.greekfontsociety.gr/GFS_GARALDUS.zip'
+ 'http://www.greekfontsociety.gr/GFS_IGNACIO.zip')
+md5sums=('891a6e880ca0ef06223eedfab7c0e035'
+ 'adcb048bdca18dd243c0337bdb0c5ecd'
+ 'b54eea11af83c569b861a17800fb1945'
+ '02fcaf05448bb0df6696567975014132'
+ '73d235051292e23bc807c71d8c951e6b'
+ '7638996769c9162f0d8b8885c18af68f'
+ 'ec397b1199ca79404adec355eeb5c163')
+build() {
+ install -d $pkgdir/usr/share/fonts/OTF/
+ install -Dm644 $srcdir/GFS*/*otf $pkgdir/usr/share/fonts/OTF/
+ install -d $pkgdir/usr/share/licenses/$pkgname/
+ install -Dm644 $srcdir/GFS_AMBROSIA/OFL* $pkgdir/usr/share/licenses/$pkgname
+}
+
+
+# vim:set ts=2 sw=2 et:
diff --git a/otf-gfs-majuscule.install b/otf-gfs-majuscule.install
new file mode 100644
index 000000000000..4b77955a6a4f
--- /dev/null
+++ b/otf-gfs-majuscule.install
@@ -0,0 +1,13 @@
+post_install()
+{
+ echo -n "Updating font cache..."
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade()
+{
+ post_install
+}