summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Delacourt2015-06-11 22:47:15 +0200
committerGuillaume Delacourt2015-06-11 22:47:15 +0200
commitdddeddc99d8b888e3b2c9acb37fd5b5df4dc0ab8 (patch)
treefcae8295c0330ae3255effd75ddef5c247e69a9f
downloadaur-dddeddc99d8b888e3b2c9acb37fd5b5df4dc0ab8.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--gnutypewriter.install20
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cf9ee276a0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-gnutypewriter
+ pkgdesc = A free font imitating a real typewriter.
+ pkgver = 20110624
+ pkgrel = 2
+ url = http://openfontlibrary.org/font/gnutypewriter
+ install = gnutypewriter.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://openfontlibrary.org/assets/downloads/gnutypewriter/8a7cb57723df9125503083ed59e7a11c/gnutypewriter.zip
+ md5sums = 8a7cb57723df9125503083ed59e7a11c
+
+pkgname = otf-gnutypewriter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe1ab3581af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: feufochmar <feufochmar.gd@gmail.com>
+pkgname=otf-gnutypewriter
+pkgver=20110624
+pkgrel=2
+pkgdesc="A free font imitating a real typewriter."
+arch=('any')
+url="http://openfontlibrary.org/font/gnutypewriter"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=gnutypewriter.install
+source=("http://openfontlibrary.org/assets/downloads/gnutypewriter/8a7cb57723df9125503083ed59e7a11c/gnutypewriter.zip")
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/share/fonts/OTF
+ install -m644 *.otf "$pkgdir"/usr/share/fonts/OTF/
+}
+md5sums=('8a7cb57723df9125503083ed59e7a11c')
diff --git a/gnutypewriter.install b/gnutypewriter.install
new file mode 100644
index 000000000000..4f5212ef22ba
--- /dev/null
+++ b/gnutypewriter.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*