summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Briggs2020-07-02 17:49:10 -0700
committerMax Briggs2020-07-02 17:49:10 -0700
commitf627f6af752b721c9fca65c7af90522b746532e7 (patch)
treee981192885df20b810aede00c374dbaec4bcaf1b
downloadaur-f627f6af752b721c9fca65c7af90522b746532e7.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ef3c939ef13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = otf-gt40
+ pkgdesc = A free recreation of the GT 40 Mono Font by Kate Willaert
+ pkgver = 1
+ pkgrel = 1
+ url = https://archive.org/download/gt-40-mono-font/GT40%20Mono%20Font.zip
+ arch = any
+ license = custom
+ source = otf-gt40-1.zip::https://archive.org/download/gt-40-mono-font/GT40%20Mono%20Font.zip
+ sha256sums = 0bbf729c7bba82ecc7646d1f96f88236e79e00efff09393489e205be1554fee5
+
+pkgname = otf-gt40
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1638978e6d2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Max Briggs <max@maxbriggs.org>
+pkgname=otf-gt40
+pkgver=1
+pkgrel=1
+pkgdesc='A free recreation of the GT 40 Mono Font by Kate Willaert'
+url='https://archive.org/download/gt-40-mono-font/GT40%20Mono%20Font.zip'
+license=('custom')
+arch=('any')
+source=("${pkgname}-${pkgver}.zip::$url")
+sha256sums=('0bbf729c7bba82ecc7646d1f96f88236e79e00efff09393489e205be1554fee5')
+
+build() {
+ sed -n '/This recreation/p' "GT40 Mono README.txt" > LICENSE
+}
+
+package() {
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 "GT40 Mono.otf" "$pkgdir/usr/share/fonts/OTF/GT40 Mono.otf"
+ install -Dm644 "GT40 Mono Italic.otf" "$pkgdir/usr/share/fonts/OTF/GT40 Mono Italic.otf"
+}