summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2017-12-19 20:46:01 +0000
committerJonathon Fernyhough2017-12-19 20:46:01 +0000
commitf7020cb4ab0a9b94c7e5c345b5696b49ad2f23dc (patch)
tree47eb59c3c4e2fe7266dfed769e32255715a86ca0
downloadaur-f7020cb4ab0a9b94c7e5c345b5696b49ad2f23dc.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1b231dce5d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-ibm-plex-git
+ pkgdesc = IBM Plex Mono, Sans, and Serif typefaces (OTF version)
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/IBM/type
+ arch = any
+ license = sil
+ makedepends = git
+ provides = otf-ibm-plex
+ conflicts = otf-ibm-plex
+ source = otf-ibm-plex::git+https://github.com/IBM/type.git
+ sha256sums = SKIP
+
+pkgname = otf-ibm-plex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..086cb49d69fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
+
+pkgname=otf-ibm-plex-git
+_pkgname=otf-ibm-plex
+pkgver=latest
+pkgrel=1
+pkgdesc='IBM Plex Mono, Sans, and Serif typefaces (OTF version)'
+arch=('any')
+url='https://github.com/IBM/type'
+license=('sil')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+source=("${_pkgname}::git+https://github.com/IBM/type.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ ( set -o pipefail
+ git describe --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$_pkgname"
+
+ for variant in Mono Sans Serif; do
+ install -d $pkgdir/usr/share/fonts/OTF/ibm-plex/${variant,,}
+ install -Dm644 fonts/${variant}/desktop/mac/*.otf $pkgdir/usr/share/fonts/OTF/ibm-plex/${variant,,}
+ done
+
+ # License
+ install -Dm644 fonts/Mono/desktop/mac/license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+}