summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2017-06-08 14:26:07 -0300
committerMarcos Heredia2017-06-08 14:26:07 -0300
commita466e3122ec077fcf62e377b3f5f4efb8bcdb1c5 (patch)
treec1dbd664c5ec7d91e03b225c126669e48d3244c9
downloadaur-a466e3122ec077fcf62e377b3f5f4efb8bcdb1c5.tar.gz
Update 4.020-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--updatefont.install15
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc1542825fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 5.0.1
+# Thu Jun 8 17:23:16 UTC 2017
+pkgbase = otf-impallari-raleway-family
+ pkgdesc = Matt McInerney's Raleway family, from Pablo Impallari
+ pkgver = 4.020
+ pkgrel = 1
+ url = http://www.impallari.com/
+ install = updatefont.install
+ arch = any
+ groups = impallari-fonts
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ provides = otf-raleway
+ conflicts = otf-raleway
+ conflicts = ttf-impallari-raleway-family
+ source = raleway-family-4.020.zip::https://github.com/impallari/Raleway/archive/master.zip
+ md5sums = 643bfae379a973891fd5251db6f6b7a9
+
+pkgname = otf-impallari-raleway-family
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..084d82c95602
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Marcos Heredia <chelqo@gmail.com>
+
+_font="raleway-family"
+_group="impallari"
+pkgname=otf-${_group}-${_font}
+pkgver=4.020
+_pkgver=v4020
+pkgrel=1
+pkgdesc="Matt McInerney's Raleway family, from Pablo Impallari"
+arch=(any)
+url="http://www.impallari.com/"
+license=('custom:OFL')
+groups=("${_group}-fonts")
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('otf-raleway' 'ttf-impallari-raleway-family')
+provides=('otf-raleway')
+install=updatefont.install
+source=("${_font}-${pkgver}.zip::https://github.com/impallari/Raleway/archive/master.zip")
+md5sums=('643bfae379a973891fd5251db6f6b7a9')
+
+package() {
+ cd ${srcdir}/Raleway-master/
+
+ install -dm755 "${pkgdir}/usr/share/fonts/OTF/${_group}"
+ install -Dpm644 fonts/${_pkgver}/*.otf "${pkgdir}/usr/share/fonts/OTF/${_group}"
+
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dpm644 CONTRIBUTORS.txt FONTLOG.txt README.md "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/updatefont.install b/updatefont.install
new file mode 100644
index 000000000000..faecb13a885f
--- /dev/null
+++ b/updatefont.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}