summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbohoomil2015-07-29 08:50:51 +0200
committerbohoomil2015-07-29 08:50:51 +0200
commita4aee0a91abe7911430ff9560c076367ef34aaa6 (patch)
tree2e472b2e05e7ae46321f68da78deac680fba7acd
downloadaur-a4aee0a91abe7911430ff9560c076367ef34aaa6.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--45-inconsolata-lgc.conf12
-rw-r--r--90-non-tt-inconsolata-lgc.conf23
-rw-r--r--PKGBUILD36
-rw-r--r--otf-inconsolata-lgc.install14
5 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9304f5742a2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.0
+# Mon Jan 19 01:28:34 UTC 2015
+pkgbase = otf-inconsolata-lgc
+ pkgdesc = Monospace font for pretty code listings and for the terminal, with Cyrillic and Greek support.
+ pkgver = 1.12
+ pkgrel = 3
+ url = http://github.com/MihailJP/Inconsolata-LGC
+ install = otf-inconsolata-lgc.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ source = http://bohoomil.com/src/inconsolata-lgc.tar.bz2
+ source = http://bohoomil.com/src/inconsolata-lgc.tar.bz2.sig
+ source = 45-inconsolata-lgc.conf
+ source = 90-non-tt-inconsolata-lgc.conf
+ sha1sums = 933f0cf5d0f55e2e8211cb85a4698f6229573908
+ sha1sums = SKIP
+ sha1sums = 58a5c6d496ab66eb9a26b8625b6f2e6a491320a4
+ sha1sums = 8b44fe50ceff3063acfefeafe8f1963f9fa97fc5
+
+pkgname = otf-inconsolata-lgc
+
diff --git a/45-inconsolata-lgc.conf b/45-inconsolata-lgc.conf
new file mode 100644
index 000000000000..8c3b2afc73e3
--- /dev/null
+++ b/45-inconsolata-lgc.conf
@@ -0,0 +1,12 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+
+ <alias>
+ <family>Inconsolata LGC</family>
+ <default>
+ <family>monospace</family>
+ </default>
+ </alias>
+
+</fontconfig>
diff --git a/90-non-tt-inconsolata-lgc.conf b/90-non-tt-inconsolata-lgc.conf
new file mode 100644
index 000000000000..dc32ff3cbbef
--- /dev/null
+++ b/90-non-tt-inconsolata-lgc.conf
@@ -0,0 +1,23 @@
+<?xml version='1.0'?>
+<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
+<fontconfig>
+
+ <match target="font">
+ <test name="family">
+ <string>Inconsolata LGC</string>
+ </test>
+ <edit name="autohint" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="hintstyle" mode="assign">
+ <const>hintslight</const>
+ </edit>
+ <edit name="hinting" mode="assign">
+ <bool>true</bool>
+ </edit>
+ <edit name="antialias" mode="assign">
+ <bool>true</bool>
+ </edit>
+ </match>
+
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30f0d48dcad8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: bohoomil <@zoho.com>
+
+pkgname=otf-inconsolata-lgc
+pkgver=1.12
+pkgrel=3
+depends=('fontconfig')
+pkgdesc="Monospace font for pretty code listings and for the terminal, with Cyrillic and Greek support."
+url="http://github.com/MihailJP/Inconsolata-LGC"
+arch=('any')
+license=('custom:OFL')
+install=$pkgname.install
+#http://github.com/MihailJP/Inconsolata-LGC
+source=(http://bohoomil.com/src/inconsolata-lgc.tar.bz2{,.sig}
+ 45-inconsolata-lgc.conf
+ 90-non-tt-inconsolata-lgc.conf)
+validpgpkeys=('A9244FB5E93F11F0E975337FAE6866C7962DDE58')
+sha1sums=('933f0cf5d0f55e2e8211cb85a4698f6229573908'
+ 'SKIP'
+ '58a5c6d496ab66eb9a26b8625b6f2e6a491320a4'
+ '8b44fe50ceff3063acfefeafe8f1963f9fa97fc5')
+
+package(){
+ install -m755 -d "${pkgdir}"/usr/share/fonts/"${pkgname}"
+ install -m644 *.otf "${pkgdir}"/usr/share/fonts/"${pkgname}"
+
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.avail
+ install -m755 -d "${pkgdir}"/etc/fonts/conf.d
+ install -m644 45-inconsolata-lgc.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/45-inconsolata-lgc.conf
+ install -m644 90-non-tt-inconsolata-lgc.conf \
+ "${pkgdir}"/etc/fonts/conf.avail/90-non-tt-inconsolata-lgc.conf
+
+ cd "${pkgdir}"/etc/fonts/conf.d
+ ln -s ../conf.avail/45-inconsolata-lgc.conf .
+ ln -s ../conf.avail/90-non-tt-inconsolata-lgc.conf .
+}
diff --git a/otf-inconsolata-lgc.install b/otf-inconsolata-lgc.install
new file mode 100644
index 000000000000..5ab355ec1e6e
--- /dev/null
+++ b/otf-inconsolata-lgc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "Updating font cache..."
+ fc-cache -s
+ echo "Done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+