summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortagener-noisu2017-06-28 22:22:34 +0600
committertagener-noisu2017-06-28 23:16:00 +0600
commit5e8163530214576f16b56ba7eec390c893c8d125 (patch)
tree044ea45472be1db92fe321801b27bfbf330219f3
downloadaur-5e8163530214576f16b56ba7eec390c893c8d125.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a200d73cba4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-inconsolata-lgc-git
+ pkgdesc = a modified version of Inconsolata with added Cyrillic alphabet
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/MihailJP/Inconsolata-LGC/
+ arch = any
+ license = OFL
+ makedepends = git
+ makedepends = fontforge
+ provides = otf-inconsolata-lgc
+ conflicts = otf-inconsolata-lgc
+ source = otf-inconsolata-lgc::git+https://github.com/MihailJP/Inconsolata-LGC.git
+ md5sums = SKIP
+
+pkgname = otf-inconsolata-lgc-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8864d4a39633
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05529d67317d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# maintainer: tagener-noisu
+pkgname=otf-inconsolata-lgc
+_pkgname=inconsolata
+pkgver=1.0
+pkgrel=1
+pkgdesc="a modified version of Inconsolata with added Cyrillic alphabet"
+url="https://github.com/MihailJP/Inconsolata-LGC/"
+arch=('any')
+license=('OFL')
+makedepends=('git' 'fontforge')
+provides=($pkgname)
+conflicts=($pkgname)
+source=("$_pkgname::git+https://github.com/MihailJP/Inconsolata-LGC.git")
+md5sums=('SKIP')
+
+build() {
+ cd $_pkgname
+ make otf
+}
+
+package() {
+ cd $_pkgname
+ install -m644 -D Inconsolata-LGC.otf "$pkgdir/usr/share/fonts/OTF/InconsolataLGC.otf"
+ install -m644 -D Inconsolata-LGC-Bold.otf "$pkgdir/usr/share/fonts/OTF/InconsolataLGC-Bold.otf"
+ install -m644 -D Inconsolata-LGC-Italic.otf "$pkgdir/usr/share/fonts/OTF/InconsolataLGC-Italic.otf"
+ install -m644 -D Inconsolata-LGC-BoldItalic.otf "$pkgdir/usr/share/fonts/OTF/InconsolataLGC-BoldItalic.otf"
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# vim:ts=2:sw=2:et: