summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasato Hashimoto2015-06-20 20:17:49 +0900
committerMasato Hashimoto2015-06-20 20:17:49 +0900
commit07d43d629238592716da74569cc5e13da048a4cd (patch)
tree7d4be6766d94f7777468257a1b3301234273270d
downloadaur-07d43d629238592716da74569cc5e13da048a4cd.tar.gz
Inital import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--otf.install20
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03ac9cad0d89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = otf-ipaexfont
+ pkgdesc = Japanese outline fonts following the tradition of Japanese printing font
+ pkgver = 002.01
+ pkgrel = 1
+ url = http://ossipedia.ipa.go.jp/ipafont/
+ install = otf.install
+ arch = any
+ license = custom
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = ttf-ipaex
+ replaces = ttf-ipaex
+ source = http://jaist.dl.sourceforge.jp/ipafonts/57330/IPAexfont00201.zip
+ md5sums = 7bf84182a04a9632268dbcb03f100d05
+
+pkgname = otf-ipaexfont
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..640a660b5fc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+pkgname=otf-ipaexfont
+pkgver=002.01
+_pkgver=${pkgver//./}
+pkgrel=1
+pkgdesc="Japanese outline fonts following the tradition of Japanese printing font"
+arch=('any')
+url="http://ossipedia.ipa.go.jp/ipafont/"
+license=('custom')
+depends=('fontconfig' 'xorg-font-utils')
+conflicts=('ttf-ipaex')
+replaces=('ttf-ipaex')
+install=otf.install
+_mirror="jaist" # "jaist" "iij" "osdn" "keihanna"
+source=(http://${_mirror}.dl.sourceforge.jp/ipafonts/57330/IPAexfont${_pkgver}.zip)
+md5sums=('7bf84182a04a9632268dbcb03f100d05')
+
+package() {
+ cd "${srcdir}/IPAexfont${_pkgver}"
+
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+ install -m644 *.ttf "${pkgdir}/usr/share/fonts/OTF/"
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 IPA_Font_License_Agreement_v1.0.txt Readme_IPAexfont${_pkgver}.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..c4c61ba10523
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*
+