summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2016-12-05 15:44:08 +0300
committerCaleb Maclennan2016-12-05 15:44:08 +0300
commit7046078601587e8e01c8481421e3f9d4aa9283dc (patch)
treeef4b199fc7c6d8f8feabf64f2d1576f1a40b3a3b
downloadaur-7046078601587e8e01c8481421e3f9d4aa9283dc.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dfd54ea29e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Dec 5 12:43:58 UTC 2016
+pkgbase = otf-iwona
+ pkgdesc = Open Type Iwona font
+ pkgver = 0.995
+ pkgrel = 1
+ url = http://jmn.pl/kurier-i-iwona/
+ arch = any
+ license = CUSTOM
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = otf-iwona-0.995.zip::http://jmn.pl/pliki/Iwona-otf-0_995.zip
+ sha256sums = 2740d5c2a5efd29fc01eaa9ba29b4bd06295c5305092f9c1cfd4366e27502caa
+
+pkgname = otf-iwona
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd0efb800555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=otf-iwona
+pkgver=0.995
+pkgrel=1
+pkgdesc="Open Type Iwona font"
+arch=('any')
+url="http://jmn.pl/kurier-i-iwona/"
+license=('CUSTOM')
+depends=('fontconfig' 'xorg-font-utils')
+source=("$pkgname-$pkgver.zip::http://jmn.pl/pliki/Iwona-otf-0_995.zip")
+sha256sums=('2740d5c2a5efd29fc01eaa9ba29b4bd06295c5305092f9c1cfd4366e27502caa')
+
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+package() {
+ cd "${srcdir}/otf"
+ find . -maxdepth 1 -name '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+}
+