summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 12:11:33 +0200
committerMartin Doege2015-06-09 12:11:33 +0200
commitcfa3e4215b60328ba63a41bb70fefe17793919b0 (patch)
tree23b129252e286036b81f242fdc92ba13b14569ea
downloadaur-cfa3e4215b60328ba63a41bb70fefe17793919b0.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--otf.install20
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13faeb640782
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-junction
+ pkgdesc = A humanist sans-serif typeface
+ pkgver = 1
+ pkgrel = 2
+ url = http://theleagueofmoveabletype.com/junction/
+ install = otf.install
+ arch = any
+ license = OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://theleagueofmoveabletype.com/junction/download
+ md5sums = 0f3dc688bf23dc5cafc325d9e9ef8273
+
+pkgname = otf-junction
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29acabc95d1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Martin Florén <martin.floren@gmail.com>
+
+pkgname=otf-junction
+pkgver=1
+pkgrel=2
+pkgdesc="A humanist sans-serif typeface"
+arch=('any')
+url="http://theleagueofmoveabletype.com/junction/"
+license=('OFL')
+depends=('fontconfig' 'xorg-font-utils')
+
+install=otf.install
+source=('http://theleagueofmoveabletype.com/junction/download')
+
+build() {
+ cd $startdir/src
+ install -Dm 644 "theleagueof-junction-18de841/Junction.otf" $pkgdir/usr/share/fonts/OTF/junction.otf
+}
+md5sums=('0f3dc688bf23dc5cafc325d9e9ef8273')
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..52655ed5cff5
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*