summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluxcem2020-02-23 21:46:35 +0100
committerluxcem2020-02-23 21:46:35 +0100
commitf7f7db6f418f7874f01609cf6dae96a7da11e2a0 (patch)
tree695fe33fe6f29ded1ea11d59e6f1cf280f8e95de
parent1270ba7a5241701ad9a166140f019c5527142306 (diff)
downloadaur-f7f7db6f418f7874f01609cf6dae96a7da11e2a0.tar.gz
Update url to use https.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rw-r--r--otf.install15
3 files changed, 15 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38c16f0cc569..76d8fc45cef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Dec 6 08:02:01 UTC 2016
pkgbase = otf-kokoro
pkgdesc = Japanese slender font (Mincho-style) based on IPA Font v3
pkgver = 1
pkgrel = 4
- url = http://typingart.net/
- install = otf.install
+ url = https://typingart.net/?p=46
arch = any
license = custom:IPA Font License
- makedepends = unzip
depends = fontconfig
- depends = xorg-font-utils
- options = debug
- options = !strip
- source = http://typingart.net/fontdata/kokoro.zip
- md5sums = a4aec0cda52c8291dd692e1ebc0deae2
+ source = https://typingart.net/fontdata/kokoro.zip
+ sha256sums = e4566175799d52f9e3b6dd8774596428ea27dd40596e1283aa627689e5ac98d8
pkgname = otf-kokoro
diff --git a/PKGBUILD b/PKGBUILD
index 8d2151b41fa8..1f8867b6682a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
-# Maintainer: kusanaginoturugi <kusanaginoturugi at gmail dot com>
+# Maintainer: luxcem <a@luxcem.fr>
+# Contributor: kusanaginoturugi <kusanaginoturugi at gmail dot com>
-options=(debug !strip)
pkgname=otf-kokoro
pkgver=1
pkgrel=4
pkgdesc="Japanese slender font (Mincho-style) based on IPA Font v3"
-arch=('any')
-url="http://typingart.net/"
-license=('custom:IPA Font License')
-depends=('fontconfig' 'xorg-font-utils')
-makedepends=('unzip')
-install=otf.install
-source=("http://typingart.net/fontdata/kokoro.zip")
-md5sums=('a4aec0cda52c8291dd692e1ebc0deae2')
-
-DLAGENTS=("http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u --referer ${url}")
+url="https://typingart.net/?p=46"
+license=("custom:IPA Font License")
+arch=("any")
+depends=("fontconfig")
+source=("https://typingart.net/fontdata/kokoro.zip")
+sha256sums=("e4566175799d52f9e3b6dd8774596428ea27dd40596e1283aa627689e5ac98d8")
+# Official source is typingart.net but does not support download without
+# the official Referer header.
+DLAGENTS=("https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u --referer ${url}")
package() {
- cd ${srcdir}/
-
install -d "${pkgdir}/usr/share/fonts/OTF"
install -m644 *.otf "${pkgdir}/usr/share/fonts/OTF/"
install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 IPA_Font_License_Agreement_v1.0.txt \
- read_me.txt \
- "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 IPA_Font_License_Agreement_v1.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/"LICENCE
}
diff --git a/otf.install b/otf.install
deleted file mode 100644
index 2158e59eac20..000000000000
--- a/otf.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- echo -n "Updating font cache... "
- fc-cache -f >/dev/null
- mkfontscale /usr/share/fonts/OTF
- mkfontdir /usr/share/fonts/OTF
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}