summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Maibaum2016-01-22 12:11:55 +0100
committerJohannes Maibaum2016-01-22 12:11:55 +0100
commit78c13f2b6320ac6449ad4339d21d2d6e1a83f1d1 (patch)
treed8c93923f5ef5700667fe1141fcf5b81ec5797bd
parent42f52811d173793bb751bcd097b82706f04c5571 (diff)
downloadaur-78c13f2b6320ac6449ad4339d21d2d6e1a83f1d1.tar.gz
Add GPL to the licenses, and correctly set attributes for font files.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eb9878cd14c..f52fa1cff97a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Jan 22 10:10:51 UTC 2016
+# Fri Jan 22 11:02:58 UTC 2016
pkgbase = otf-libertinus
pkgdesc = The Libertinus font family. A fork of the Linux Libertine and Linux Biolinum fonts with bugfixes and an OpenType math companion.
pkgver = 6.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/khaledhosny/libertinus
install = otf-libertinus.install
arch = any
license = custom: OFL
+ license = GPL
depends = fontconfig
depends = xorg-mkfontdir
conflicts = otf-libertine-git
+ conflicts = otf-libertinus-git
source = https://github.com/khaledhosny/libertinus/archive/v6.1.tar.gz
sha256sums = 2c5a32e08d7601ffdc86e52d69dc1d19acfd118ec5bb549073a3cbeb969e74be
diff --git a/PKGBUILD b/PKGBUILD
index 351bdccb04a6..f9d9aa38858a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=otf-libertinus
_pkgname=${pkgname/otf-/}
pkgver=6.1
-pkgrel=1
+pkgrel=2
pkgdesc="The Libertinus font family. A fork of the Linux Libertine and Linux Biolinum fonts with bugfixes and an OpenType math companion."
depends=('fontconfig' 'xorg-mkfontdir')
-conflicts=('otf-libertine-git')
+conflicts=('otf-libertine-git' 'otf-libertinus-git')
arch=('any')
-license=('custom: OFL')
+license=('custom: OFL' 'GPL')
url="https://github.com/khaledhosny/libertinus"
install=$pkgname.install
source=("https://github.com/khaledhosny/${_pkgname}/archive/v${pkgver}.tar.gz")
@@ -15,8 +15,8 @@ sha256sums=('2c5a32e08d7601ffdc86e52d69dc1d19acfd118ec5bb549073a3cbeb969e74be')
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- mkdir -p $pkgdir/usr/share/fonts/OTF
- cp *.otf $pkgdir/usr/share/fonts/OTF
- install -Dm644 LICENCE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -m644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/OFL"
+ find . -name '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ install -Dm644 LICENCE.txt "${pkgdir}/usr/share/licenses/${pkgname#-*}/LICENSE"
+ install -m644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname#-*}/LICENSE-OFL"
+ install -m644 GPL.txt "${pkgdir}/usr/share/licenses/${pkgname#-*}/LICENSE-GPL"
}