summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Maibaum2016-01-21 14:16:25 +0100
committerJohannes Maibaum2016-01-21 14:16:25 +0100
commitea5ac82418a991ee2fa8368265584e14b8fc6303 (patch)
tree0bc108817e1a12c59b64d557b5795deb408183fb
downloadaur-ea5ac82418a991ee2fa8368265584e14b8fc6303.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--otf-libertinus.install11
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96d58cbd454e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 13:12:33 UTC 2016
+pkgbase = otf-libertinus
+ pkgdesc = The Libertinus font family. A fork of the Linux Libertine and Linux Biolinum fonts with bugfixes and an OpenType math companion.
+ pkgver = 6.0
+ pkgrel = 1
+ url = https://github.com/khaledhosny/libertinus
+ install = otf-libertinus.install
+ arch = any
+ license = custom: OFL
+ depends = fontconfig
+ depends = xorg-mkfontdir
+ conflicts = otf-libertine-git
+ source = https://github.com/khaledhosny/libertinus/archive/v6.0.tar.gz
+ sha256sums = f73d0c1b3a64aee4ad1473458e69321d4c5bb506fca5d7975f712f9ce0f50379
+
+pkgname = otf-libertinus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b3ad755cc3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Johannes Maibaum <jmaibaum@gmail.com>
+pkgname=otf-libertinus
+_pkgname=${pkgname/otf-/}
+pkgver=6.0
+pkgrel=1
+pkgdesc="The Libertinus font family. A fork of the Linux Libertine and Linux Biolinum fonts with bugfixes and an OpenType math companion."
+depends=('fontconfig' 'xorg-mkfontdir')
+conflicts=('otf-libertine-git')
+arch=('any')
+license=('custom: OFL')
+url="https://github.com/khaledhosny/libertinus"
+install=$pkgname.install
+source=("https://github.com/khaledhosny/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('f73d0c1b3a64aee4ad1473458e69321d4c5bb506fca5d7975f712f9ce0f50379')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ mkdir -p $pkgdir/usr/share/fonts/OTF
+ cp *.otf $pkgdir/usr/share/fonts/OTF
+ install -Dm644 LICENCE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/OFL"
+}
diff --git a/otf-libertinus.install b/otf-libertinus.install
new file mode 100644
index 000000000000..fe67c839b69b
--- /dev/null
+++ b/otf-libertinus.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}