summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2018-05-22 04:31:06 +0200
committeraksr2018-05-22 04:31:06 +0200
commit22e36ecb595327ac4295833f91ec6de93dce80b4 (patch)
tree20ca6ce846ec770504e8a247b3251cc355b39e5c
parentf81063ef27636d97d1fc0d557ed195f7b8a0ea9f (diff)
downloadaur-22e36ecb595327ac4295833f91ec6de93dce80b4.tar.gz
Fix installation.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ee17d8e8b3..8fdf58ace9bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 1 12:57:22 UTC 2018
+# Tue May 22 02:30:44 UTC 2018
pkgbase = otf-libertinus-git
pkgdesc = Libertinus font family, a fork of Linux Libertine and Linux Biolinum with bugfixes and an OpenType math companion.
- pkgver = 6.4.r73.g4656f77
+ pkgver = 6.6.r19.g51a9651
pkgrel = 1
url = https://github.com/khaledhosny/libertinus
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 76a1eeba07b7..f3f077f7fcbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=otf-libertinus-git
-pkgver=6.4.r73.g4656f77
+pkgver=6.6.r19.g51a9651
pkgrel=1
pkgdesc='Libertinus font family, a fork of Linux Libertine and Linux Biolinum with bugfixes and an OpenType math companion.'
arch=('any')
@@ -15,13 +15,15 @@ source=("$pkgname::git+https://github.com/khaledhosny/libertinus.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$pkgname"
- find -name '*.otf' -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/OTF/{}" \;
- install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+ cd "$srcdir/$pkgname"
+ for f in *.otf; do
+ install -D -m644 $f "$pkgdir/usr/share/fonts/OTF/$f"
+ done
+ install -D -m644 OFL.txt "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}