summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2020-08-20 08:29:37 -0500
committerPedro A. López-Valencia2020-08-20 08:29:37 -0500
commit0bb2788d15ddd61bb244086a4b037258bc20ad60 (patch)
tree94661a348b67ff816dd363cf94e7527206a28ffa
parentc903c50623ccd3d26ca1771366dd6a72bbd1bc2b (diff)
downloadaur-0bb2788d15ddd61bb244086a4b037258bc20ad60.tar.gz
Fix checksums problem. I hope.
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8915a7cd4251..2b3ebf4089ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
pkgbase = otf-literata
pkgdesc = Google's default typeface for Play Books. Android distribution.
pkgver = 2.00
- pkgrel = 1
+ pkgrel = 2
url = https://play.google.com/store/apps/details?id=com.google.android.apps.books
arch = any
license = custom:propietary
+ makedepends = git
depends = fontconfig
depends = xorg-font-util
conflicts = ttf-literata
replaces = ttf-literata
- source = https://gitlab.com/vorbote/lit/-/blob/master/lit.otf
- source = https://gitlab.com/vorbote/lit/-/blob/master/liti.otf
- source = https://gitlab.com/vorbote/lit/-/blob/master/litb.otf
- source = https://gitlab.com/vorbote/lit/-/blob/master/litbi.otf
- b2sums = f9786aa3152e63c38d9f3274a06edffb59a41b1cc3ac294d24bb819458396872a8117557562909a0e1da4bf98c413486cab5f4f0b6d78e4839d45da2a6730be9
- b2sums = 7242c9f3edaeea6e9c4a0cd5a8d8c1850cdba9345352165464c68614fd75f26d90550462f6ff644cd5d6fdc75c262842a964b3e7af2d35b39ce32fd14219ddeb
- b2sums = 36db3ab9e4f7bad889c6ba48ecc5eba08738c8426baa9ac567c498cd3f125886bc66d95502ed0f65bccade89e6f92a10dc44f8b4593ebd06fcd690d482f1bc9d
- b2sums = c721534e5a9cf44a997f2f2b0ea3d38f2115afe61d987b71c80ed07493b2d3a1496e92df6dc1054efd5125ba32e2e26821081e647bd9b2e47650556b5b99cb9f
+ source = otf-literata::git+https://gitlab.com/vorbote/lit
+ b2sums = SKIP
pkgname = otf-literata
diff --git a/.gitignore b/.gitignore
index 95b8e67c426c..c40ebb1c9f16 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
+otf-literata/
*.tar.*
*.otf
diff --git a/PKGBUILD b/PKGBUILD
index b5954d7e9ceb..315a4891b3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
# Contributor: Andrejs Mivreņiks <gim at fastmail dot fm>
pkgname=otf-literata
pkgver=2.00
-pkgrel=1
+pkgrel=2
pkgdesc="Google's default typeface for Play Books. Android distribution."
arch=('any')
url="https://play.google.com/store/apps/details?id=com.google.android.apps.books"
license=('custom:propietary')
depends=('fontconfig' 'xorg-font-util')
+makedepends=('git')
conflicts=('ttf-literata')
replaces=('ttf-literata')
#
# If this doesn't work, please let me know. I may need to find an alternative solution.
#
-source=(
- "https://gitlab.com/vorbote/lit/-/blob/master/lit.otf"
- "https://gitlab.com/vorbote/lit/-/blob/master/liti.otf"
- "https://gitlab.com/vorbote/lit/-/blob/master/litb.otf"
- "https://gitlab.com/vorbote/lit/-/blob/master/litbi.otf"
-)
-b2sums=('f9786aa3152e63c38d9f3274a06edffb59a41b1cc3ac294d24bb819458396872a8117557562909a0e1da4bf98c413486cab5f4f0b6d78e4839d45da2a6730be9'
- '7242c9f3edaeea6e9c4a0cd5a8d8c1850cdba9345352165464c68614fd75f26d90550462f6ff644cd5d6fdc75c262842a964b3e7af2d35b39ce32fd14219ddeb'
- '36db3ab9e4f7bad889c6ba48ecc5eba08738c8426baa9ac567c498cd3f125886bc66d95502ed0f65bccade89e6f92a10dc44f8b4593ebd06fcd690d482f1bc9d'
- 'c721534e5a9cf44a997f2f2b0ea3d38f2115afe61d987b71c80ed07493b2d3a1496e92df6dc1054efd5125ba32e2e26821081e647bd9b2e47650556b5b99cb9f')
+source=(otf-literata::git+https://gitlab.com/vorbote/lit)
+
+b2sums=('SKIP')
package() {
- cd "$srcdir"
+ cd "$srcdir/$pkgname"
install -dm755 "$pkgdir/usr/share/fonts/OTF/literata"