summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedro A. López-Valencia2023-11-21 13:05:32 -0500
committerPedro A. López-Valencia2023-11-21 13:05:32 -0500
commit2b571f70e7c21600bdff6b124ae69b369214f7b5 (patch)
tree9e01d5aa4a20847e0b1ac93c252e47b59ff38d16
parente3bc0236efdd39600bc0034228cb3943a313521a (diff)
downloadaur-2b571f70e7c21600bdff6b124ae69b369214f7b5.tar.gz
* Fix PKGBUILD.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f28461053e89..f83ae0842d54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = otf-literata
pkgdesc = Google's contemporary serif typeface family for long-form reading; default typeface for Play Books. Android distribution.
pkgver = 2.00
- pkgrel = 3
+ pkgrel = 4
url = https://play.google.com/store/apps/details?id=com.google.android.apps.books
arch = any
license = custom:propietary
@@ -10,7 +10,5 @@ pkgbase = otf-literata
replaces = ttf-literata-opticals
replaces = ttf-literata-webfonts
replaces = ttf-literata-webfonts-opticals
- source = otf-literata::git+https://gitlab.com/vorbote/lit
- b2sums = SKIP
pkgname = otf-literata
diff --git a/PKGBUILD b/PKGBUILD
index 2a27bb302225..b08a24604d5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andrejs Mivreņiks <gim at fastmail dot fm>
pkgname=otf-literata
pkgver=2.00
-pkgrel=3
+pkgrel=4
pkgdesc="Google's contemporary serif typeface family for long-form reading; default typeface for Play Books. Android distribution."
arch=('any')
url="https://play.google.com/store/apps/details?id=com.google.android.apps.books"
@@ -10,16 +10,14 @@ license=('custom:propietary')
makedepends=('git')
replaces=('ttf-literata' 'ttf-literata-opticals' 'ttf-literata-webfonts' 'ttf-literata-webfonts-opticals')
#
-# If this doesn't work, please let me know. I may need to find an alternative solution.
+# Obtain a copy of the "Google Play Books & Audiobooks" and extract the fonts. Place them in the same
+# directory as this PKGBUILD.
#
-source=(otf-literata::git+https://gitlab.com/vorbote/lit)
-b2sums=('SKIP')
package() {
- cd "$srcdir/$pkgname"
+ cd "$startdir"
install -dm755 "$pkgdir/usr/share/fonts/OTF"
-
install -m644 lit*.otf "$pkgdir/usr/share/fonts/OTF"
}