summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-09-07 11:40:30 +0200
committerSefa Eyeoglu2022-09-07 11:40:30 +0200
commit6631e3e31a56e949683c997d450e69b079c0fb35 (patch)
tree9382afcb58dc37e936c3c267c380f6e51b088604
downloadaur-6631e3e31a56e949683c997d450e69b079c0fb35.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..484de9104fea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = otf-monocraft
+ pkgdesc = A programming font based on the typeface used in Minecraft
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/IdreesInc/Monocraft
+ arch = any
+ license = custom:OFL
+ source = Monocraft-1.1.tar.gz::https://github.com/IdreesInc/Monocraft/archive/refs/tags/v1.1.tar.gz
+ sha256sums = d2c52ccda44d34af2087863eae51099840977a638702ffccca791ec28671154e
+
+pkgname = otf-monocraft
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfcd10f04178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+pkgname=otf-monocraft
+pkgver=1.1
+pkgrel=1
+pkgdesc="A programming font based on the typeface used in Minecraft"
+arch=(any)
+url="https://github.com/IdreesInc/Monocraft"
+license=('custom:OFL')
+source=("Monocraft-$pkgver.tar.gz::https://github.com/IdreesInc/Monocraft/archive/refs/tags/v1.1.tar.gz")
+sha256sums=('d2c52ccda44d34af2087863eae51099840977a638702ffccca791ec28671154e')
+
+
+package() {
+ cd "Monocraft-$pkgver"
+
+ install -Dm644 "Monocraft.otf" "$pkgdir/usr/share/fonts/OTF/Monocraft.otf"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}