summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsai Alcântara2019-12-10 21:03:47 -0300
committerIsai Alcântara2019-12-10 21:03:47 -0300
commit3d89fa1240ce86e7c16b15f0989859cf3656f19d (patch)
treef557430a30aca6204e0391f29a47d84f0a19f64f
downloadaur-3d89fa1240ce86e7c16b15f0989859cf3656f19d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4821e53323fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = otf-mplus
+ pkgdesc = M+, the japanese outline font families designed by Coji Morishita.
+ pkgver = 063_OTF
+ pkgrel = 1
+ url = https://mplus-fonts.osdn.jp/about-en.html
+ arch = any
+ license = custom
+ depends = fontconfig
+ conflicts = ttf-mplus
+ source = https://osdn.net/projects/mplus-fonts/downloads/62344/063-OTF.tar.xz
+ sha256sums = b1a98b24e034ff26d7cb957d904f1d49bbffc004c732eadc822e140b99f98ce1
+
+pkgname = otf-mplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a30e471604f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Isai Alcântara <isfalcantara[at]gmail[dot]com>
+pkgname=otf-mplus
+_pkgname=mplus
+pkgver=063_OTF
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc="M+, the japanese outline font families designed by Coji Morishita."
+arch=('any')
+url="https://mplus-fonts.osdn.jp/about-en.html"
+license=('custom')
+depends=('fontconfig')
+conflicts=('ttf-mplus')
+source=("https://osdn.net/projects/mplus-fonts/downloads/62344/${_pkgver}.tar.xz")
+sha256sums=('b1a98b24e034ff26d7cb957d904f1d49bbffc004c732eadc822e140b99f98ce1')
+package() {
+ cd ${srcdir}/${_pkgver}
+
+ install -d ${pkgdir}/usr/share/fonts/${_pkgname}
+ install -m644 *.otf ${pkgdir}/usr/share/fonts/${_pkgname}/
+
+ install -D -m644 LICENSE_E ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_E
+ install -D -m644 LICENSE_J ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_J
+}