summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Kugland2021-07-28 16:46:58 -0300
committerAndré Kugland2021-07-28 16:46:58 -0300
commitef1b3e414f715dc277e179810e63d8939db9e5c9 (patch)
tree4fc598ca6ed01ce9d7f936d58d8d500dbf8c30e9
downloadaur-ef1b3e414f715dc277e179810e63d8939db9e5c9.tar.gz
v1.1.26
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e9494a36772
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = otf-murty-gurmukhi
+ pkgdesc = Gurmukhi Typeface from Harvard's Murty Classical Library of India (free for non-commercial/scholarly use)
+ pkgver = 1.1.26
+ pkgrel = 1
+ url = https://murtylibrary.com/design-and-typography.php
+ arch = any
+ license = custom
+ noextract = Murty-Gurmukhi.zip
+ source = http://www.hup.harvard.edu/features/mcli/fonts/Murty-Gurmukhi.zip
+ sha256sums = 5c0e1c7d629570d2ffb8004165a47866ea7b0bcfc121f86371cf7f3da9c59abf
+
+pkgname = otf-murty-gurmukhi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..726f8cec9b7a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+/__MACOSX
+/pkg
+/src
+/._*
+*.txt
+*.zip
+*.otf
+*.pkg.tar
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e04a101b868d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: André Kugland <kugland at gmail dot com>
+
+_pkglang=Gurmukhi
+pkgname=otf-murty-"$(echo "$_pkglang" | tr '[:upper:]' '[:lower:]')"
+pkgver=1.1.26
+pkgrel=1
+pkgdesc="${_pkglang} Typeface from Harvard's Murty Classical Library of India (free for non-commercial/scholarly use)"
+arch=(any)
+url="https://murtylibrary.com/design-and-typography.php"
+license=('custom')
+source=("http://www.hup.harvard.edu/features/mcli/fonts/Murty-${_pkglang}.zip")
+noextract=("${source[@]##*/}")
+sha256sums=('5c0e1c7d629570d2ffb8004165a47866ea7b0bcfc121f86371cf7f3da9c59abf')
+
+prepare() {
+ cd "$srcdir"
+ rm *.otf >/dev/null 2>&1 || true
+ rm ._*.* >/dev/null 2>&1 || true
+ unzip -o -q -j Murty-"${_pkglang}".zip '*.otf' '*.txt'
+ mv Murty*"${_pkglang}"*".otf" "$_pkglang.otf"
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/Murty/" "${_pkglang}.otf"
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/${pkgname}/" "EULA-Murty-${_pkglang}.txt"
+}