summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Kugland2021-07-28 16:47:44 -0300
committerAndré Kugland2021-07-28 16:47:44 -0300
commita916a3bb38316cee00217ec139d0466e9f7c6fb7 (patch)
treeef5da2aff29b86af5abafed4956a2cb721696875
downloadaur-a916a3bb38316cee00217ec139d0466e9f7c6fb7.tar.gz
v1.2.44
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caeee94fd363
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = otf-murty-hindi
+ pkgdesc = Hindi Typeface from Harvard's Murty Classical Library of India (free for non-commercial/scholarly use)
+ pkgver = 1.2.44
+ pkgrel = 1
+ url = https://murtylibrary.com/design-and-typography.php
+ arch = any
+ license = custom
+ noextract = Murty-Hindi.zip
+ source = http://www.hup.harvard.edu/features/mcli/fonts/Murty-Hindi.zip
+ sha256sums = d232b1fd7186a25edbe11110f10aa61e826401d7d41e708143f2feafff72d915
+
+pkgname = otf-murty-hindi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..726f8cec9b7a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+/__MACOSX
+/pkg
+/src
+/._*
+*.txt
+*.zip
+*.otf
+*.pkg.tar
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5e0dc1cd5f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: André Kugland <kugland at gmail dot com>
+
+_pkglang=Hindi
+pkgname=otf-murty-"$(echo "$_pkglang" | tr '[:upper:]' '[:lower:]')"
+pkgver=1.2.44
+pkgrel=1
+pkgdesc="${_pkglang} Typeface from Harvard's Murty Classical Library of India (free for non-commercial/scholarly use)"
+arch=(any)
+url="https://murtylibrary.com/design-and-typography.php"
+license=('custom')
+source=("http://www.hup.harvard.edu/features/mcli/fonts/Murty-${_pkglang}.zip")
+noextract=("${source[@]##*/}")
+sha256sums=('d232b1fd7186a25edbe11110f10aa61e826401d7d41e708143f2feafff72d915')
+
+prepare() {
+ cd "$srcdir"
+ rm *.otf >/dev/null 2>&1 || true
+ rm ._*.* >/dev/null 2>&1 || true
+ unzip -o -q -j Murty-"${_pkglang}".zip '*.otf' '*.txt'
+ mv Murty*"${_pkglang}"*".otf" "$_pkglang.otf"
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/Murty/" "${_pkglang}.otf"
+ install -Dm0644 -t "$pkgdir/usr/share/fonts/${pkgname}/" "EULA-Murty-${_pkglang}.txt"
+}