summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyz3n2018-04-26 22:57:02 +0200
committerpyz3n2018-04-26 22:57:02 +0200
commita04ebef1133a38411b2b2416678943b01ad8383f (patch)
tree5c532c5e67e7fffeae050e5bf4d794a9a89a614d
downloadaur-a04ebef1133a38411b2b2416678943b01ad8383f.tar.gz
first
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66a3ae14ae1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = otf-nerd-fonts-fira-code
+ pkgdesc = Monospaced font with programming ligatures. Patched with Nerd Fonts icons.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ license = MIT
+ depends = fontconfig
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/FiraCode.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ md5sums = e5bff5da34eb6d16fb20226047c5755c
+ md5sums = 1b95f7668f3a4440b0d404e8dc3ccd9c
+
+pkgname = otf-nerd-fonts-fira-code
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfe58a3cc843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: pyz3n
+
+pkgname=otf-nerd-fonts-fira-code
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Monospaced font with programming ligatures. Patched with Nerd Fonts icons."
+arch=('any')
+url='https://github.com/ryanoasis/nerd-fonts'
+license=('MIT')
+depends=('fontconfig')
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/FiraCode.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+md5sums=('e5bff5da34eb6d16fb20226047c5755c'
+ '1b95f7668f3a4440b0d404e8dc3ccd9c')
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/OTF
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ find "$srcdir" -not -name "*Windows Compatible*" -a -name "*.otf" \
+ -exec install -Dm644 {} ${pkgdir}/usr/share/fonts/OTF \;
+ install -Dm644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+}